Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd January 2008, 15:28
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Question Virtual Users + Mysql + Squirrelmail + ChangePass Plugins Problem

Hi everyone, i have an installed and currently working email server (did it on falko's way ). I have the need of allow password changing to my users, so i was searching and the easiest way of doing this i have found is the squirrelmail + changepass plugin (If someone has some advice or any idea of another way of letting users change their passwords it will be welcome ), well anyway my problem is that i cant make it work. Im stuck on "cant connect to database" error, it seems to me that the query to connect to the database isnt well but i cant fix it, the query on the config.php of the plugin that i guess is wrong is:

$csp_dsn = 'mysql://user: password@localhost/email_users';

i replace the username and the password and the final part "email_users" that i suppose is the name of the database i will work with, with my own database called "mail", the rest of the configuration file it seems to be ok (not sure either).

i've already tested the user and password and privileges on the command line (with mysql -u user -p pass -d mail) and seems to work fine (select + update privileges over mail database).

If anyone has any idea to fix this or workaround... i will be waiting to probe it.

Thks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 3rd January 2008, 15:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are there any errors in your logs, especially Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd January 2008, 16:42
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Default

No errors. I tried using an older version with another database connection method but the result is another error of another kind, so i put back the newer one. The newer one uses Pear DB to make the connection, and i guess i have all those packages installed, but i dont know how to check if those package actually works or how to make the same connection from the command line or some other utility that let me check for more detailed errors or so :S. I used some script (that i find on the net) maded on php to "check" pear DB and guess what, it gives me an error :P (that i guess is the key), some error relative to "cant find DB package or so". I will copy & paste if needed, so i suppose it could be some missing path on php.ini or so.

The other chance is to change all to that project called RoundCube, any advice on that? at least is more beatifull than squirrel , too bad is still an alfa or so. I just need some nice webmail frontend, and allowing users to change pass i guess thats all for now.
Reply With Quote
  #4  
Old 4th January 2008, 19:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you install the php-mysql package?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th January 2008, 22:32
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Default

good one! i have installed php5-mysql package but not the php4-mysql package now i did it and im obtaining some error but is mysql query relative so it works!!!. Btw... why i have php5 support and php4 if apache2 is actually using just php4 can i uninstall all those php5 related packages?
Reply With Quote
  #6  
Old 5th January 2008, 15:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by JEU
can i uninstall all those php5 related packages?
If you're using PHP4, then yes.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL renegriffioen Server Operation 4 12th June 2007 13:28
mysql whitelisting for 'Virtual Users And Domains With Postfix, Courier And MySQL'? hnodine HOWTO-Related Questions 3 25th May 2007 22:57
ISPCONFIG and Virtual Users And Domains With Postfix, Courier And MySQL QuikSoft Installation/Configuration 5 6th December 2006 19:01
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 04:39
Virtual Users And Domains With Postfix, Courier And MySQL: POP/IMAP authentication SeanG HOWTO-Related Questions 3 1st January 2006 18:08


All times are GMT +2. The time now is 09:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.