Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st December 2005, 15:59
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Proftpd Inside Network (Very Slow)

Proftpd works perfectly outside the network but inside it is very slow, it always takes 8seconds to upload a file, i was wondering if this is normal? .. or is there some i can change to fix this ?

Cheers
Reply With Quote
Sponsored Links
  #2  
Old 31st December 2005, 18:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Where is proftpd located? Inside or outside your network? Have you tried both active and passive mode?
What's in /var/log/xferlog?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st January 2006, 12:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

If you have hostname lookups enabled in your proftpd.conf, try to disbale it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 2nd January 2006, 00:14
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
If you have hostname lookups enabled in your proftpd.conf, try to disbale it.
Ive tried both on and off and it doesnt seem to make any difference
Reply With Quote
  #5  
Old 2nd January 2006, 00:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Maybe it's the firewall on your workstation that's causing the problem. Have you tried to disable it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 2nd January 2006, 02:19
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Maybe it's the firewall on your workstation that's causing the problem. Have you tried to disable it?

Yea, ive got zonealarm pro and its the same even when disabled ...
Reply With Quote
  #7  
Old 2nd January 2006, 00:13
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Where is proftpd located? Inside or outside your network? Have you tried both active and passive mode?
What's in /var/log/xferlog?
Im on the same network as the server, i.e. server ip 192.128.0.2 and me pc 192.128.4, both active and passive are the same.

its not the actual speed of the file transfers its the time it takes to exe a command, it always takes 8 seconds before it will start the transfer and 8 seconds just for a dir listing.

In the xferlog it doesnt seem to show any errors at all ...

Outside my network where my server ip would be 80.127.122.*** the ftp server works fine, nice and fast, i was just wondering if its because im working on the same network and there is a fix i can apply or if a fault .....

Cheers
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Im thinking about throwing proftpd to the trashcan danf.1979 Installation/Configuration 2 23rd December 2005 09:27
ProFTPd Problems Logging in from outside network Ran2004 Server Operation 9 17th October 2005 00:56
Proftpd Access outside of network palkat Installation/Configuration 4 13th October 2005 18:50
proftpd problems Ovidiu Installation/Configuration 5 21st September 2005 10:47
ISPConfig ProFTPD changes? ProTrooper Installation/Configuration 3 9th September 2005 18:13


All times are GMT +2. The time now is 12:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.