#1  
Old 29th November 2007, 19:30
drmeg drmeg is offline
Junior Member
 
Join Date: Jun 2006
Location: Texas
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default DNS problem with email

I think I have a DNS problem with my emails.

I host several sites with ispconfig 2.2.18 on ubuntu 6.06 LTS using the perfect setup instructions.

All my hosted websites seem to work properly and are accessible from the web. All my hosted users can send email to anyone on the web, but can only receive email from each other.

When I DIG the MX record I get the following:

root@ws1:~# dig cslive.net mx

; <<>> DiG 9.3.2 <<>> cslive.net mx
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63686
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;cslive.net. IN MX

;; ANSWER SECTION:
cslive.net. 85015 IN MX 10 cslive.net.

;; ADDITIONAL SECTION:
cslive.net. 85015 IN A 71.41.166.18

;; Query time: 35 msec
;; SERVER: 204.117.214.10#53(204.117.214.10)
;; WHEN: Thu Nov 29 11:59:43 2007
;; MSG SIZE rcvd: 60


I think I am missing an A-record for the mail, right?
Can I fix this with ispconfig, or do I have to edit my named.conf manually?
Reply With Quote
Sponsored Links
  #2  
Old 29th November 2007, 19:53
msource msource is offline
Member
 
Join Date: May 2007
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I,

You have to create a A record like this ex:
mail A 71.41.166.18

On the MX record you have to altered for ex:
mail.cslive.net

Did you understand?

Do a DIG on liz-online.pt and you will figured out.

You could add me to gtalk in m2source@gmail.com, or leave an e-mail if you need any help.
Reply With Quote
  #3  
Old 30th November 2007, 11:17
drmeg drmeg is offline
Junior Member
 
Join Date: Jun 2006
Location: Texas
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for the help.
I added the A-record and now the DIG looks like this:

root@ws1:/# dig cslive.net mx

; <<>> DiG 9.3.2 <<>> cslive.net mx
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36034
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;cslive.net. IN MX

;; ANSWER SECTION:
cslive.net. 85322 IN MX 10 mail.cslive.net.

;; ADDITIONAL SECTION:
mail.cslive.net. 85322 IN A 71.41.166.18

;; Query time: 27 msec
;; SERVER: 204.117.214.10#53(204.117.214.10)
;; WHEN: Fri Nov 30 04:10:34 2007
;; MSG SIZE rcvd: 65


It looks like it should be working, but it still is not.
Messages are still not being received from other servers .

Any ideas?
Reply With Quote
  #4  
Old 30th November 2007, 12:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Changes in DNS may take up to 48 hours to propagate.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
drmeg (4th December 2007)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Email Delivery Problem sedat1903 HOWTO-Related Questions 2 22nd December 2008 11:19
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52
Email problem freeborn Installation/Configuration 5 19th August 2006 13:42
Postfix / DNS Problem sonoffett Installation/Configuration 14 27th May 2006 13:36
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 20:30


All times are GMT +2. The time now is 10:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.