Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st December 2005, 22:32
Dingo78 Dingo78 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default SAMBA (Domaincontroller) Server for Small Workgroups Windows

Hey All,
I have run through this entire how to and all was going well untill i got to section 4 and had to test the connection using smbclient -L localhost -U% . THis was my comupters response...

added interface ip=192.168.0.10 bcast=192.168.0.255 nmask=255.255.255.0
Client started (version 3.0.14a-Ubuntu).
resolve_wins: Attempting wins lookup for name localhost<0x20>
resolve_wins: using WINS server 127.0.0.1 and tag '*'
Got a positive name query response from 127.0.0.1 ( 127.0.0.1 )
Connecting to 127.0.0.1 at port 445
Domain=[MSHOME] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
tree connect failed: NT_STATUS_LOGON_FAILURE

Have I missed or mucked something up earlier cause i continued on from here and I can't access the box from windows... I would appreciate any and all help...

Matt
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2005, 12:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,419
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

You executed the command smbclient -L localhost -U% as root user? Do not use sudo.


If yes, please redo these two steps:

Add the root user to the SAMBA password database. The root user (alias: Administrator) will be our domain administrator. This account is needed to add new computers to the SAMBA domain.

smbpasswd -a root

Create the file /etc/samba/smbusers and add the line by executing:

echo "root = Administrator" > /etc/samba/smbusers

and try to query your server again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st January 2006, 22:36
gometro33 gometro33 is offline
Junior Member
 
Join Date: Jan 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just went through the how-to and everything has worked great except for the second to last step. When I try to access the cups webinterface from my computer it says I'm forbidden. I'm pretty sure I followed the directions as he directed. Is there anywhere I might check first? Or should I just run through the last couple parts again? Thanks
Reply With Quote
  #4  
Old 2nd January 2006, 09:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,419
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

If you see the webinterface, but cant login to some options, please run these comands again:

Add the cupsys user to the shadow group:

Code:
adduser cupsys shadow
and restart the cups daemon:


Code:
/etc/init.d/cupsys restart
If you cant reach the webinterface at all, please check if you set the options in /etc/cups/cupsd.conf in the correct sections. The option "AuthGroupName shadow" must be right below or above the AuthGroupName option that is commented out in the file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd February 2006, 04:31
chekov chekov is offline
Junior Member
 
Join Date: Feb 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default SAMBA (Domaincontroller) Server for Small Workgroups Windows - CUPS Webinterface

Quote:
Originally Posted by gometro33
I just went through the how-to and everything has worked great except for the second to last step. When I try to access the cups webinterface from my computer it says I'm forbidden. I'm pretty sure I followed the directions as he directed. Is there anywhere I might check first? Or should I just run through the last couple parts again? Thanks

Remember to add (depends how did you configure cupsd.conf file) at the end of the port number the folder name you are trying to access, i.e.:
http://192.168.0.100:631/admin. Cupsd.conf has apache-like sections for locations where you can set privileges, or better say, permissions which IP address is allowed to access certain folder of CUPS' webinterface.

I hope this helps.


Chekov
Reply With Quote
  #6  
Old 9th January 2006, 19:46
maino82 maino82 is offline
Junior Member
 
Join Date: Jan 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default samba problems

first off, thanks for the tutorial. it was well written and easy to follow.

i went through and did everything (minus setting up CUPS since i don't have a printer) and when i ran "smbclient -L localhost -U%" as root it spat this out:

added interface ip=192.168.0.100 bcast=192.168.0.255 nmask=255.255.255.0
Client started (version 3.0.14a-Ubuntu).
resolve_wins: Attempting wins lookup for name localhost<0x20>
resolve_wins: using WINS server 127.0.0.1 and tag '*'
Got a positive name query response from 127.0.0.1 ( 127.0.0.1 )
Connecting to 127.0.0.1 at port 445
Domain=[MAINO] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
dos_clean_name []

Sharename Type Comment
--------- ---- -------
netlogon Disk Network Logon Service
IPC$ IPC IPC Service (server1 server (Samba, Ubuntu))
ADMIN$ IPC IPC Service (server1 server (Samba, Ubuntu))
Connecting to 127.0.0.1 at port 139
Domain=[MAINO] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
dos_clean_name []

Server Comment
--------- -------
SERVER1 server1 server (Samba, Ubuntu)

Workgroup Master
--------- -------
MAINO SERVER1

so i'm assuming everything went well when setting everything up. however, i still cannot access my samba server from windows. the server shows up under my workgroup, but when i try to connect to it says the server is not accessible. i have tried using the "map network drive" feature to logon using various user names i created, but none have worked. is there some additional configuring that needs to be done in order to access the server?
Reply With Quote
  #7  
Old 9th January 2006, 21:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,419
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

This howto is a setup for a domaincontroller server. This means you cannot connect to it with WinXP home, only WinXP professional, Win 2000 or win98 can connect to it. You cannot simply map a network drive as this is handled by the domaincontroller when you join the domain.

To join a domain with WinXP pro:

Go to MyComputer right click on Properties. Go to Change and click on Domain and enter the domain-name you want to join. When joining the domain, you will be first asked for the username that shall join the domain, its the user that you created in linux and added to samba. Then in the next step you have to enter the Administrator user "Administrator" and enter the password for the Administrator.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA (Domaincontroller) Server For Small Workgroups With Ubuntu 5.10 Dagur Server Operation 15 16th February 2006 03:56
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
Server Not Autorative for Domain Error drbista Installation/Configuration 10 20th December 2005 16:41
How to retrive mails from 2nd server dstme Server Operation 3 1st December 2005 18:28
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 20:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.