Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd November 2007, 14:57
devilslayer devilslayer is offline
Junior Member
 
Join Date: Oct 2007
Posts: 13
Thanks: 1
Thanked 1 Time in 1 Post
Question CRON and .htaccess problems

Hello,

I have a server installed with ISPConfig and I have just installed the community script 'Dolphin' by Boonex.com.

I am having problems with CRON errors.

Below are the cron jobs that were created during the ISPConfig install:

Code:
 

30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /$
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php $
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php$
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &$
0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &$
0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_servic$
15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.p$
40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &$
05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &>$
After installing Dolphin the Dolphin installation manual asks you to add the following (email address changed!!).
Code:
MAILTO=myname@myemail.com

0 0 * * * /usr/bin/php -q /var/www/web1/web/dolphin/periodic/cmd.php
*/10 * * * * /usr/bin/php -q /var/www/web1/web/dolphin/periodic/notifies.php
*/10 * * * * /usr/bin/php -q /var/www/web1/web/dolphin/periodic/tags.php
I am now receiving eroor messages delivered to my email address:

Code:
PHP Warning:  Module 'json' already loaded in Unknown on line 0 PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0 
I assume this is to do with the new entries that I put in for Dolphin, as I wasn't getting them before.
I have had to remove the CRON jobs that i created after installing Dolphin as was getting error messages to my email address every 10 minutes. (Yes about 100 a day!!) eekk!!

I am also having images failing to appear that I have narrowed down to .htaccess files. One of the fil3es only contained the code below:

[CODE]I have managed to get the images showing. I already had installed GD and ImageMagick, so I knew that wasn't the problem.

The problem was the .htaccess files, in each image directory. For some reason they were causing the images not to show. To test I renamed one to .htaccess123 and the images in that directory appeared.

Now all I need to find out is what in the .htaccess was causing the images not to display.

For example, one of the .htaccess files only contained the code below. I renamed the .htaccess to .htaccess123 and the images in that directory then appeared on the website.

Code:
Options -Indexes
Why would this stop images displaying?

I am not that familiar with .htaccess files and apache directives.

Is this due to settings that are already installed by ISPConfig?

Thanks for your help.
Reply With Quote
Sponsored Links
  #2  
Old 23rd November 2007, 16:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Go to that web site in ISPConfig and enter the following into the Apache Directives field (assuming that /var/www/web1/web is your document root):

Code:
<Directory /var/www/web1/web>
 AllowOverride All
</Directory>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
.htaccess Liac Server Operation 15 20th June 2007 15:19
eGroupWare Install crudolphy General 28 5th June 2007 19:09
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09
.htaccess never executed galmiche Server Operation 2 4th June 2006 21:44


All times are GMT +2. The time now is 06:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.