Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th December 2005, 18:18
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default plenty of procmail/trashscan processes

ok, the problem concerning the wrong zlib-package was solved.
what stays are those many many many pairs of procmail- & trashscan-processes
last time I had a look at them (20 mins after restarting the machine) there were more than 2500 processes only from user admispconfig.

it looked like this:

Code:
# ps -u admispconfig
  PID TTY          TIME CMD
14994 ?        00:00:00 ispconfig_httpd
15289 ?        00:00:00 freshclam
15295 ?        00:00:00 procmail
15296 ?        00:00:00 procmail
15297 ?        00:00:00 trashscan
15305 ?        00:00:00 procmail
15306 ?        00:00:00 procmail
15307 ?        00:00:00 trashscan
15315 ?        00:00:00 procmail
15316 ?        00:00:00 procmail
15317 ?        00:00:00 trashscan
15325 ?        00:00:00 procmail
15326 ?        00:00:00 procmail
15327 ?        00:00:00 trashscan
15335 ?        00:00:00 procmail
15336 ?        00:00:00 procmail
15337 ?        00:00:00 trashscan
15345 ?        00:00:00 procmail
15346 ?        00:00:00 procmail
15347 ?        00:00:00 trashscan
15355 ?        00:00:00 procmail
15356 ?        00:00:00 procmail
15357 ?        00:00:00 trashscan
15365 ?        00:00:00 procmail
15366 ?        00:00:00 procmail
15367 ?        00:00:00 trashscan
15375 ?        00:00:00 procmail
15376 ?        00:00:00 procmail
15377 ?        00:00:00 trashscan
15385 ?        00:00:00 procmail
15386 ?        00:00:00 procmail
15387 ?        00:00:00 trashscan
15397 ?        00:00:00 procmail
15398 ?        00:00:00 procmail
15399 ?        00:00:00 trashscan
15407 ?        00:00:00 procmail
15408 ?        00:00:00 procmail
15409 ?        00:00:00 trashscan
15417 ?        00:00:00 procmail
15418 ?        00:00:00 procmail
15419 ?        00:00:00 trashscan
15427 ?        00:00:00 procmail
15428 ?        00:00:00 procmail
15429 ?        00:00:00 trashscan
15437 ?        00:00:00 procmail
15438 ?        00:00:00 procmail
15439 ?        00:00:00 trashscan
15447 ?        00:00:00 procmail
15448 ?        00:00:00 procmail
15449 ?        00:00:00 trashscan
15457 ?        00:00:00 procmail
15458 ?        00:00:00 procmail
15459 ?        00:00:00 trashscan
15467 ?        00:00:00 procmail
this is only a little part of the whole output I got
Reply With Quote
Sponsored Links
  #2  
Old 19th December 2005, 18:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you have something like a mail loop? What's in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st December 2005, 17:41
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

these are the last few lines from /var/log/mail

Quote:
Dec 21 17:31:01 kassel072 popper[31506]: Stats: web2_psc 0 0 0 0 p549ABC8E.dip0.t-ipconnect.de 84.154.188.142 [pop_updt.c:296]
Dec 21 17:31:13 kassel072 sendmail-client[27950]: jBKMxQ0L027950: to=root, delay=13:30:22, xdelay=00:00:00, mailer=relay, pri=72662296, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:31:13 kassel072 sendmail-client[27950]: jBKN0W9Y030485: to=root, ctladdr=root (0/0), delay=17:30:41, xdelay=00:00:00, mailer=relay, pri=93900976, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:31:31 kassel072 popper[31515]: web1_psc at p549ABC8E.dip0.t-ipconnect.de (84.154.188.142): -ERR [SYS/PERM] Unable to process From lines (envelopes), change recognition modes or check for corrupted mail drop. [pop_dropcopy.c:839]
Dec 21 17:31:56 kassel072 popper[31520]: web1_psc at p549ABC8E.dip0.t-ipconnect.de (84.154.188.142): -ERR [SYS/PERM] Unable to process From lines (envelopes), change recognition modes or check for corrupted mail drop. [pop_dropcopy.c:839]
Dec 21 17:32:13 kassel072 sendmail-client[27950]: jBKMxQ0L027950: to=root, delay=13:31:22, xdelay=00:00:00, mailer=relay, pri=72752296, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:32:13 kassel072 sendmail-client[27950]: jBKN0W9Y030485: to=root, ctladdr=root (0/0), delay=17:31:41, xdelay=00:00:00, mailer=relay, pri=93990976, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:33:14 kassel072 sendmail-client[27950]: jBKMxQ0L027950: to=root, delay=13:32:23, xdelay=00:00:00, mailer=relay, pri=72842296, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:33:14 kassel072 sendmail-client[27950]: jBKN0W9Y030485: to=root, ctladdr=root (0/0), delay=17:32:42, xdelay=00:00:00, mailer=relay, pri=94080976, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:34:14 kassel072 sendmail-client[27950]: jBKMxQ0L027950: to=root, delay=13:33:23, xdelay=00:00:00, mailer=relay, pri=72932296, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:34:14 kassel072 sendmail-client[27950]: jBKN0W9Y030485: to=root, ctladdr=root (0/0), delay=17:33:42, xdelay=00:00:00, mailer=relay, pri=94170976, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:35:14 kassel072 sendmail-client[27950]: jBKMxQ0L027950: to=root, delay=13:34:23, xdelay=00:00:00, mailer=relay, pri=73022296, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Dec 21 17:35:14 kassel072 sendmail-client[27950]: jBKN0W9Y030485: to=root, ctladdr=root (0/0), delay=17:34:42, xdelay=00:00:00, mailer=relay, pri=94260976, relay=[127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
this is what /var/log/mail.err tells me: (the dying processes may be killed by me, but I'm not sure)

Quote:
Dec 19 17:49:04 kassel072 sendmail[10705]: jBJ33M6P010705: SYSERR(root): mailer prog died with signal 9
Dec 19 17:49:04 kassel072 sendmail[23198]: jBJ6XNCw023198: SYSERR(root): mailer prog died with signal 9
Dec 19 17:49:04 kassel072 sendmail[6657]: jBJGXRCw006657: SYSERR(root): mailer prog died with signal 9
Dec 19 17:49:04 kassel072 sendmail[16416]: jBJBXOCw016416: SYSERR(root): mailer prog died with signal 9
Dec 19 17:49:04 kassel072 sendmail[18641]: jBJC3PCw018641: SYSERR(root): mailer prog died with signal 9
Dec 19 17:51:41 kassel072 sendmail-client[3280]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 18:14:18 kassel072 sendmail-client[24961]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 18:46:29 kassel072 sendmail-client[15198]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 18:48:40 kassel072 sendmail-client[19581]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 18:49:09 kassel072 sendmail-client[22752]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 20:58:40 kassel072 sendmail-client[23095]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 21:40:33 kassel072 sendmail-client[30933]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 19 21:42:49 kassel072 sendmail-client[3296]: persistent queue runner control process: lost all children: wait returned ECHILD
Dec 20 03:08:36 kassel072 sendmail[3744]: have been rejecting connections on daemon MTA for 04:38:28
Dec 20 22:46:55 kassel072 sendmail[20538]: jBJL2N8J002325: SYSERR(root): openmailer: setuid(108) failed: Resource temporarily unavailable
Dec 20 23:59:12 kassel072 sendmail-client[3221]: persistent queue runner control process: lost all children: wait returned ECHILD
but actually this tells me nothing. email-daemons are not my world
Reply With Quote
  #4  
Old 21st December 2005, 19:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Ok, you're using Sendmail. Which distribution are you using?

What's in /etc/mail/sendmail.cf?

Also, please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st December 2005, 19:51
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Distro: SuSe 9.2


Quote:
# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 1350/xinetd
tcp 0 0 *:mysql *:* LISTEN 3149/mysqld-max
tcp 0 0 *:pop3 *:* LISTEN 1350/xinetd
tcp 0 0 *:imap *:* LISTEN 1350/xinetd
tcp 0 0 *:sunrpc *:* LISTEN 3008/portmap
tcp 0 0 *:ndmp *:* LISTEN 3013/perl
tcp 0 0 *:hosts2-ns *:* LISTEN 32291/ispconfig_htt
tcp 0 0 *:ftp *:* LISTEN 1350/xinetd
tcp 0 0 atora.nwn-server:domain *:* LISTEN 32553/named
tcp 0 0 localhost:domain *:* LISTEN 32553/named
tcp 0 0 localhost:953 *:* LISTEN 32553/named
tcp 0 0 atora.nwn-server.de:ftp p549ABC8E.dip0.t-:63716 ESTABLISHED 17172/vsftpd
tcp 0 0 atora.nwn-server.de:ftp p54B4D788.dip.t-d:62341 ESTABLISHED 20623/vsftpd
tcp 0 0 *:www-http *:* LISTEN 6799/httpd2-prefork
tcp 0 0 *:ssh *:* LISTEN 3107/sshd
tcp 0 0 localhost:953 *:* LISTEN 32553/named
tcp 0 1628 atora.nwn-server.de:ssh p549ABC8E.dip0.t-:63530 ESTABLISHED 364/1
tcp 0 0 atora.nwn-serv:www-http viva2-214-dynamic:54109 TIME_WAIT -
tcp 0 0 atora.nwn-server.de:ssh p549ABC8E.dip0.t-:63307 ESTABLISHED 31287/0
/etc/sendmail.cf is located under : http://nopaste.php-q.net/179737
yeah I know there are many comments in it - but deleting them all would last to long

Last edited by ZyanKLee; 21st December 2005 at 19:57.
Reply With Quote
  #6  
Old 21st December 2005, 22:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Sendmail isn't running at all! Start it:
Code:
/etc/init.d/sendmail start
The sendmail.cf looks ok, so hopefully your problem will disappear afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what to do about zombie processes ? Ovidiu Technical 10 7th September 2007 08:55


All times are GMT +2. The time now is 12:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.