#1  
Old 18th December 2005, 22:15
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default procmail <defunct>

I notice many defunctional procmail-processes after some time of running the server.

Code:
# ps -A | grep procmail
 3659 ?        00:00:00 procmail
 3730 ?        00:00:00 procmail
 3731 ?        00:00:00 procmail <defunct>
 3750 ?        00:00:00 procmail
32634 ?        00:00:00 procmail <defunct>
32661 ?        00:00:00 procmail
 3790 ?        00:00:00 procmail
 3809 ?        00:00:00 procmail
 3822 ?        00:00:00 procmail
 3858 ?        00:00:00 procmail
 3990 ?        00:00:00 procmail <defunct>
 3999 ?        00:00:00 procmail
 4277 ?        00:00:00 procmail <defunct>
 4286 ?        00:00:00 procmail
 4967 ?        00:00:00 procmail <defunct>
 4981 ?        00:00:00 procmail
 5746 ?        00:00:00 procmail <defunct>
 5758 ?        00:00:00 procmail
 8921 ?        00:00:00 procmail
 8930 ?        00:00:00 procmail
and this occures after nearly 2 hours of uptime:

Code:
# uptime
 10:12pm  up   1:48,  1 user,  load average: 1.51, 1.59, 1.66
ispconfig is running on suse 9.2 with procmail v3.22

does anybody know if there is a known bug with this software?
Reply With Quote
Sponsored Links
  #2  
Old 19th December 2005, 00:58
ZyanKLee ZyanKLee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, if anybody runs in this problem too: update zlib to version >1.2.2 except of disabling the testing for the correct version

now it runs smoothly
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Procmail not delivering to mailboxes crudolphy Server Operation 3 9th February 2006 19:13
customized procmail setup jmroth Installation/Configuration 4 5th December 2005 21:20
procmail supposed to be in main.cf? Smitty Installation/Configuration 4 5th December 2005 10:10
Procmail radioguy General 1 17th August 2005 13:38


All times are GMT +2. The time now is 20:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.