Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th October 2007, 01:25
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default Where does ISPConfig expect to see server and private kys

Hi, Folks,

This has probably been done before, but I can't do a search because the adverts are totally blocking the search function (FF on Deb Etch <edit>sorry, it's on Ubuntu current version, it's my server which is on Etch</edit>).

Would someone please tell me where ISPConfig would expect to find the server and private keys, respectively, on an SSL enabled domain on an Etch server? Then I can set up the VHosts configuration properly.

Many thanks, in anticipation.

Last edited by chancer; 13th October 2007 at 21:37.
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2007, 10:45
chuckl chuckl is offline
Senior Member
 
Join Date: May 2007
Location: Uxbridge, Middlesex, UK
Posts: 166
Thanks: 1
Thanked 20 Times in 20 Posts
Default

If you want to enable SSL on a particular website, tick the SSL checkbox for the website and save. This enables an SSL config tab for the site.

I believe they are stored in the /webXX/ssl folder.
Reply With Quote
  #3  
Old 13th October 2007, 21:35
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

Thanks, chukl. Now, I've got a cert from CAcert - should I put that in /webxx/ssl first, or how do I tell ISPConfig where it is now (which is in the wrong place )
Reply With Quote
  #4  
Old 13th October 2007, 21:51
chuckl chuckl is offline
Senior Member
 
Join Date: May 2007
Location: Uxbridge, Middlesex, UK
Posts: 166
Thanks: 1
Thanked 20 Times in 20 Posts
Default

While I'm a Cacert assurer as well, it's a while since I've done this, as I use a homebrew multidomain on 1 IP setup.
The ISPConfig technique, is that you take the Certificate and paste it into the text box provided for the site under the SSL tab that appears when you enable SSL.
I just have a nasty suspicion that you should use a CSR generated in the same place (the SSL tab) for the certificate generation. i.e. generate the signing request there, and cut and paste that into the CaCert form.
ISPConfig then parks the certificate in the correct place for the site, and sets up the paths etc for the secure connection in the Vhosts file.
Thinking about that, that probably takes care of the key, as the ISPConfig key is used to generate the CSR.
You may need to grab the CaCert certificate chain file as well and put it in the ssl folder.
Reply With Quote
  #5  
Old 13th October 2007, 23:02
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

Thanks, once again chuckl. I've never done a ssl cert before. I'm trying to help a few people get into business online so would like to learn my way around alll this and become a CAcert assurer myself.

Perhaps I should go back into the CAcert site and cancel the one I generated, then redo the request via ISPConfig?
Reply With Quote
  #6  
Old 13th October 2007, 23:10
chuckl chuckl is offline
Senior Member
 
Join Date: May 2007
Location: Uxbridge, Middlesex, UK
Posts: 166
Thanks: 1
Thanked 20 Times in 20 Posts
Default

I would definitely suggest that, yes. Generate a CSR in ISPConfig for that site, and cut and paste into an editor. Head for Cacert, cancel the existing one and reissue with the ISPConfig generated CSR, then when the cert arrives, paste into the site SSL tab field.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgraded but forgot password.. ispconfig server dont start - what now? teveo1 Installation/Configuration 2 30th August 2007 10:00
Virtual Private Server voxanBoxer Installation/Configuration 3 9th August 2007 22:21
ISPConfig didn't start on server restart TheRudy Installation/Configuration 3 7th July 2006 18:25
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16
Server Not Autorative for Domain Error drbista Installation/Configuration 10 20th December 2005 17:41


All times are GMT +2. The time now is 10:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.