Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th December 2005, 02:32
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Question Error installing with Suse10 on x64

Hi!

I have a Dell PowerEdge P4 x64 computer with a fresh install of Suse 10 and ISPConfig 2.1.1.

I have already check every topic on 64bit installation and do everything that ppl says and that fix some problems but I'm still having this error message:

configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP

Anyone know which file need to be modified to fix this problem?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 7th December 2005, 09:27
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Have you installed the openssl devel rpm packages?
Reply With Quote
  #3  
Old 7th December 2005, 13:04
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

yes! I have done every tips in this thread:
http://www.howtoforge.com/forums/showthread.php?t=127
and this one as well:
http://www.howtoforge.com/forums/sho...0&postcount=12
and some others.

That fix some of the problems but I'm still having this one.

Just before this error, it was the Cannot find OpenSSL's <evp.h> error but some modifications fixed this one.

I already have ISPConfig on a Dual P3 server with Suse 9.3 and it's working very well.

Thanks!

Last edited by SeaWolf; 7th December 2005 at 13:07.
Reply With Quote
  #4  
Old 7th December 2005, 13:41
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Have you tried with "--with-openssl" or with "--with-openssl=/path/to/openssl/libs" ?
Reply With Quote
  #5  
Old 7th December 2005, 14:04
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

yep, tried that too without success
Reply With Quote
  #6  
Old 7th December 2005, 15:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the exact error message you get now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 7th December 2005, 16:56
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Cool

Ok, I've just installed from scratch Suse 10 with the Perfect Setup and install ISPConfig. I will let you know all error msg appear when I do some mods.

Fresh install, Suse Linux 10 on 64bit P4 computer with ISPConfig 2.1.1.

Here we go:

Quote:
Without modifications:
configure: error: Cannot find libmysqlclient under /usr.
Note that the MySQL client library is not bundled anymore.
ERROR: Could not configure PHP
Quote:
Modifications 1 (
mkdir /usr/local/lib/mysql
cd /usr/local/lib/mysql
ln -s /usr/include/mysql include
ln -s /usr/lib64/mysql lib
and change that line:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
)

configure: error: Cannot find OpenSSL's <evp.h>
ERROR: Could not configure PHP
Quote:
Modifications 2 (
All modifications 1 +
install openssl-devel
)

configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP
Quote:
Modifications 3 (
All modifications 2 +
change that line:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=/usr/include/openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
)

configure: error: Cannot find OpenSSL's <evp.h>
ERROR: Could not configure PHP
I've deleted all files before each tries and all error messages apears in "Configuring extensions" section.

If you have other ideas lemme know!

Hope it will help!

Thanks.

Last edited by SeaWolf; 7th December 2005 at 17:02.
Reply With Quote
  #8  
Old 7th December 2005, 17:24
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Smile

Hi again!

I just do the Modifications3 + change the ./configure line to:

./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=${INSTALL_ROOT}/openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --without-zlib || error "Could not configure PHP"

And now the error is:

/usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld: /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
/root/ispconfig/openssl/lib/libssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
ERROR: Could not make PHP

Any ideas?

Thanks!

SeaWolf
Reply With Quote
  #9  
Old 7th December 2005, 17:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

If you use --with-openssl=${INSTALL_ROOT}/openssl it uses the OpenSSL that comes with ISPConfig, but this OpenSSL definetly wont work on 64 bit systems.

Try to use: --with-openssl or --with-openssl=/path/to/openSSL/from/suse
Reply With Quote
  #10  
Old 8th December 2005, 22:07
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Default

Do you have another idea? I've reinstall again Suse 10 with all update that yast ask me in the install, then install openssl-devel and finally when I install ISPConfig, I got this error again

Configuring extensions
checking whether to enable LIBXML support... no
checking libxml2 install dir... no
checking for OpenSSL support... yes
checking for Kerberos support... no
checking for pkg-config... no
configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP


Someone wanna take a look?

SeaWolf
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.