#1  
Old 24th August 2007, 00:45
phreeman phreeman is offline
Junior Member
 
Join Date: Feb 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSL and Google Checkout

I'm trying to configure the Google checkout feature to a ZenCart e-commerce site running on suse10.2 configured with ISPConfig. I'm having a problem with the security certificate. I tried to follow the suggestions in the thread:

http://www.howtoforge.net/forums/showthread.php?t=1854

but still no joy. the site is working fine on both IE and firefox but google is rejecting the certificate.

Running: # openssl s_client -connect www.mysite.com:443 -showcerts < /dev/null

shows:

CONNECTED(00000003)
depth=3 /L=ValiCert Validation Network/O=ValiCert, Inc./OU=ValiCert Class 2 Policy Validation Authority/CN=http://www.valicert.com//emailAddress=info@valicert.com
verify error:num=19:self signed certificate in certificate chain
verify return:0
---
Certificate chain
0 s:/O=www.mysite.com/OU=Domain Control Validated/CN=www.mysite.com
i:/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certificates.godaddy.com/repository/CN=Go Daddy Secure Certification Authority/serialNumber=xxxxxxxx
-----BEGIN CERTIFICATE-----
etc.

(changed the domain and xx'd out the serial number)

I've added the httpd directive suggested by mjrpes (in the reference post, page 3) for the intermediate certificate and copied the .crt file to the /web2/ssl directory. I then restarted apache.
I then added my site certificate using the control panel and again restarted apache.

I trying to get a clean SSL chain so Google can properly call-back to my shopping cart. Any idea what I'm doing wrong in setting up the godaddy certificates? Your help is greatly appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 24th August 2007, 10:07
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

You must upload the SSL cert in ISPConfig by copyibg it to the correct field on the SSL tab and the select save as action and not copy it to the ssl cert directory manually.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th August 2007, 17:45
phreeman phreeman is offline
Junior Member
 
Join Date: Feb 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I thought I had done just that. I re-tried loading the intermediate certificate, set the hpptd directive, restarted apache. I then re-enterd the SSL cert through the ISP config control panel SSL tab and saved. Restarted apache and the SSL is now working through Google checkout. I'm still receiving the same response for the openssl command but it doesn't seem to affect the https transfers.

Thanks much for the help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Curl with ssl ProServ-uk.com Server Operation 8 26th October 2007 13:25


All times are GMT +2. The time now is 12:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.