Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st August 2007, 16:57
gaspiman gaspiman is offline
Junior Member
 
Join Date: Nov 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default High CPU load on Debian Etch + Suhosin

Hi Falko,

I want to report a very annoying bug. We have lost one day to figure it out. Form time to time when calling a simple php script (ex. phpinfo() the CPU on our server hits 100% caused by apache2.

After the apache server is restarted, everything is back to normal for a period of time (20min to 1 hour). Then again calling the small php script the CPU is at 100% - apache2 is taking 100%.

So after investigating and testing different setups we have found out that this problem is caused by SUHOSIN - installed based on the tutorial in How to forge.

Apparently we are not the only ones. http://forum.hardened-php.net/viewtopic.php?id=283

Removing SUHOSIN fixed the issue immediately. Here is our setup:

Debian Etch/ Apache 2.2.3 / PHP 5.2 / CPU Dual Core2 1,3 GHz / 2 GB Ram / 2x320GB HDD/

Hope this info is helpful.
Reply With Quote
Sponsored Links
  #2  
Old 22nd August 2007, 12:07
gaspiman gaspiman is offline
Junior Member
 
Join Date: Nov 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok - it wasn't Suhosin's fault.

After a while the problem showed up again. The CPU skyrocketed every time a PHP script was called.

What we did: We disabled all unneeded Apache modules and the same with the PHP extensions. We also removed Memcached.

For now everything is fine and the CPU is at 0 - 1,2 % which is perfect. We still have no idea what was wrong.

Once we have a clue, I'll post an update.

Hope this is helpful.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
average cpu load = 3% is that high? adam Server Operation 12 10th October 2006 14:23
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Server sometimes (1 or 2 hrs) down :/ edge Server Operation 25 31st July 2006 13:44
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 10:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.