Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th August 2007, 01:04
owl700 owl700 is offline
Junior Member
 
Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Zimbra on Ubuntu, please help me with 2 problem

Hi, i have installed Zimbra on Ubuntu thanks to Howto
Now i have 2 problems:

1 - If i have understand right Zimbra don't request mta/smtp user authentication when you send emails via smtp with a client in local network with Zimbra.
es. zimbra server stmp ip 10.10.0.3
email client ip 10.0.0.2
Is this right?
How can i force mta/stmp to authenticate a client in local network? I have seen that if you use a fake user with a fake domain you can however send emails... why?

2 - Zimbra use external dns servers also for delivery local mail? I don't have a dns server, for now, to add an A and a MX record for my test domain. There is a mode to tell zimbra to delivery local mail without a record mx?

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 12th August 2007, 10:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,245 Times in 4,111 Posts
Default

1) run the command:

postconf -e 'mynetworks = 127.0.0.0/8'

and then restart postfix to deny relaying for clients in your network without authentication.

2) Add a line like this to the /etc/hosts file on your server to override external DNS settings:

192.168.0.100 yourdomain.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th August 2007, 11:38
owl700 owl700 is offline
Junior Member
 
Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I thanks you a lot! Now i can authenticate local network )))))))))
But i try the fase 2 of your halp and i still no recevice local mail, i think i have do a mistake.

My hosts

127.0.0.1 localhost.localdomain localhost
10.10.0.3 mail.domainname.com mail

i have modified in

127.0.0.1 localhost.localdomain localhost
10.10.0.3 mail.domainname.com

but still no local mail arrive

Can you help?
Reply With Quote
  #4  
Old 12th August 2007, 13:56
thanis thanis is offline
Member
 
Join Date: Aug 2007
Location: somewhere over the rainbox
Posts: 30
Thanks: 0
Thanked 7 Times in 7 Posts
Default

Hi, Zimbra definitely needs a DNS Server as it requires an A- and an MX-record. Since you do not have a DNS domain yet (I presume), I would suggest installing a local DNS server (e.g. BIND) and then configure your own domain there.

After installing and configuring Bind (setup forwarders to your ISP's dns!), just edit the /etc/resolv.conf file and point it to 127.0.0.1 or your server's IP address.

Also, remove the lines in your /etc/hosts as they will only cause confusion and other errors later on !

Kind regards,
Thanis
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
UTF8 ubuntu problem gzero HOWTO-Related Questions 7 13th January 2007 07:28
About installing ddclient satimis Server Operation 32 21st December 2006 03:51
Log for Debugging jwan Installation/Configuration 5 27th October 2006 14:34
VMWare install on Ubuntu problem with the IP velonis HOWTO-Related Questions 10 21st September 2006 14:19


All times are GMT +2. The time now is 11:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.