Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th November 2005, 12:38
benjami benjami is offline
Member
 
Join Date: Nov 2005
Location: Mediterranean Sea > Majorca Island
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default ./install doesn't create database

For some reason the 2 installations --in Debian 3.1-- doesn't created the ISPConfig database.

In the second installation I've created the database manually, but after the installation the database was empty.

I've seen the user (root) and password correct in the configuration file (/home/admispconfig/ispconfig/config.inc.php).

I've located the db_ispconfig.sql file in the tarball (ISPConfig-2.1.1.tar.gz). I've manually filled up the database:

$ mysql -u root -p ipcdb < db_ispconfig.sql
Enter password:

Seems that ISP Config works, but is possible that come up some problem because the ./install process can't filled up the database?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 25th November 2005, 15:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by benjami
For some reason the 2 installations --in Debian 3.1-- doesn't created the ISPConfig database.

In the second installation I've created the database manually, but after the installation the database was empty.
Dont create the database manually! The installer will fail.

Quote:
I've seen the user (root) and password correct in the configuration file (/home/admispconfig/ispconfig/config.inc.php).

I've located the db_ispconfig.sql file in the tarball (ISPConfig-2.1.1.tar.gz). I've manually filled up the database:

$ mysql -u root -p ipcdb < db_ispconfig.sql
Enter password:

Seems that ISP Config works, but is possible that come up some problem because the ./install process can't filled up the database?
If you filled the database in manually, ISPConfig wont work because all the system specific settings are missing.

You will have to uninstall ISPConfig and run the installer again. Have a look in the ispconfig_install.log in the directory /var/log if there are any errors.
Reply With Quote
  #3  
Old 25th November 2005, 17:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

As Till said, don't install the database manually.

Have a look here to find out how to configure your system and prepare it for ISPConfig:
http://www.howtoforge.com/perfect_setup_debian_sarge
http://www.ispconfig.org/manual_installation.htm

There's a little chance that you succeed with your current installation if you read this thread: http://www.howtoforge.com/forums/showthread.php?t=161
Of course, there's no guarantee that this works...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 26th November 2005, 14:25
benjami benjami is offline
Member
 
Join Date: Nov 2005
Location: Mediterranean Sea > Majorca Island
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, till and falco!

The /var/log/ispconfig_install.log is very useful.

The first error is due to «Line 1037: WARNING: could not read in db_ispconfig.sql». Then I've manually created the database. The second error: «db ipcf already exists!», and my manual dump that have problems --can't change the IP and server name with ISPConfig web.

The last installation after your recommendations is correct, thanks

(PS: about this thread title: is ./setup, not ./install! %-)

Last edited by benjami; 26th November 2005 at 14:27.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Client Website MySQL Database Names Lister Installation/Configuration 4 12th January 2008 17:21
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
Ability to Select Database Name / Username SleeperZ Tips/Tricks/Mods 17 19th April 2007 11:45
apache user/group won't create directory weedguy Installation/Configuration 6 19th September 2005 23:40
Install stopped at: create clamav.tar.gz domino Installation/Configuration 2 16th August 2005 06:36


All times are GMT +2. The time now is 21:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.