Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 8th July 2007, 15:29
koekbr koekbr is offline
Junior Member
 
Join Date: Jul 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default ispconfig on a system with a desktop

Can ispconfig be installed on a system with a gnome desktop, the reason i ask is after installing ispconfig and rebooting the system, my system holts at gdmgreeter and does not display the graphical loginin screen.

After searching on the net, i have found some users saying that ispconfig is for pure servers only. Is this correct, as all functions of isp config work perfectley, until you reboot the system and then you just cant login.

Just a note, i followed the How To - The perfect server Fedora 7 exactly.
ispconfig works perfectly.
Now problems with system or hardware.
Fedora 7 System
Installed with desktop and server functionality.

Can anyone help me.
If i never turn the system of i can run ispconfig and server perfectly with no problems. But as soon as i reboot i just cant log back in. (ETSA Utilities doing electrical work in the house and had to turn power of for 1 hour otherwise i would of never turmed the system of)

Please help.
Sponsored Links
  #2  
Old 8th July 2007, 18:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

ISPConfig does not interfere with gnome. You can install it on a linux desktop as well as on a server, it makes no difference for ISPConfig or gnome.

I do not think that your problem is caused by ISPConfig. But I'am not a expert for gdmgreeter to tell you what causes this software to hang.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #3  
Old 8th July 2007, 19:32
koekbr koekbr is offline
Junior Member
 
Join Date: Jul 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

All i know is that i follow the how to perfect server fedora 7, i update via yum, and i can use the gnome desktop as usual (after boot i get the login screen),Then after the whole how to, i reboot and all is still good. So i proceed to install ispconfig (this is all that is installed) then reboot and i cant get to login screen. (installed via /root/install_ispconfig/ ./setup)

I tried ctrl + alt + f1 and used top and the PID it was stuck on was gdmgreeter so im asuming this is the error, it may not be. All i know is that everything is fine with my system until i install ispconfig (i dont install anything else) then i cannot log in. I really dont want to go back to leased licence of plesk, does anyone know what can be wrong.

Last edited by koekbr; 8th July 2007 at 19:35.
  #4  
Old 8th July 2007, 19:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Did you follow the ISPConfig installation isnstructions http://www.ispconfig.org/manual_installation.htm and entered "n" in step 7 and 8 of the SSL certificate createion process? If not, it might be that your start scripts are waiting that you enter the SSL password before they proceed.

If you encrypted your SSL certificate by not choosing "n" during setup, please create new certificates on the shell as described here:

http://www.howtoforge.com/forums/sho...t=firefox+8182
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #5  
Old 9th July 2007, 05:24
koekbr koekbr is offline
Junior Member
 
Join Date: Jul 2007
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No i did not encrypt the ssl certificates. This is why i dont know what the error can be. It is really frustrating.
  #6  
Old 9th July 2007, 09:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Please disable the startup of the ISPConfig server by running:

chkconfig --levels 235 ispconfig_server off

and then reboot your server. Are you now able to login?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.3.2-dev released till General 9 4th June 2007 11:46
Can't access ISPConfig on 2 month old system. digerata Installation/Configuration 3 21st August 2006 17:30
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! max Installation/Configuration 6 13th January 2006 23:07
Backup? ctroyp Installation/Configuration 7 28th December 2005 12:33


All times are GMT +2. The time now is 08:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.