Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd July 2007, 16:24
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default Add new website: folders OK but still "shared IP" notice

I reinstalled Debian 4.0 through the perfect setup yesterday, everything was fine, added about 26 websites, all fine.
But when I add another website now as admin but for one of my reseller accounts it does make the domain, it does make the /var/www/webXX/ folder but it still gives a shared IP when I type in the address, even after uploading files.

The site does *not* appear in /etc/apache2/vhosts/Vhosts_ispconfig.conf nor in one of the backup files. But before (the other 26 sites) it did...

This also appears when I add the site under Admin (just tested it).

When I restart Apache I get this:

Code:
server:~# /etc/init.d/apache2 restart
Forcing reload of web server (apache2)...[Mon Jul 02 16:22:06 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
[Mon Jul 02 16:22:16 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
.
server:~#
I already tried to comment out some of the virtual host things as in one of the howtos here on the site but it didn't help.
And now I cannot add any sites, or I have to manually edit the /etc/apache2/vhosts/Vhosts_ispconfig.conf-file every time...

Anybody any suggestions on this?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 2nd July 2007, 18:28
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Do you have the line:

Include /etc/apache2/vhosts/Vhosts_ispconfig.conf

At the very end within your apache2 configuration file which is /etc/apache2/apache2.conf ?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #3  
Old 2nd July 2007, 18:37
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Hans
Do you have the line:

Include /etc/apache2/vhosts/Vhosts_ispconfig.conf

At the very end within your apache2 configuration file which is /etc/apache2/apache2.conf ?
yes, the last line is (copy/paste from the actual file):

Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
Reply With Quote
  #4  
Old 2nd July 2007, 22:41
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

I found out that everytime I make a new domain it will make a new file, like:

Vhosts_ispconfig.conf_02-07-07_22-02-29
Vhosts_ispconfig.conf_02-07-07_22-02-16
Vhosts_ispconfig.conf_02-07-07_22-02-02
Vhosts_ispconfig.conf_02-07-07_21-50-15

etc. and these do contain the updated versions!
I renamed the last one to Vhosts_ispconfig.conf and it does work, though the error is still there... (the [warn] thing)
Reply With Quote
  #5  
Old 3rd July 2007, 09:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Please have a look here:

http://www.howtoforge.com/forums/showthread.php?t=13596
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 3rd July 2007, 10:16
djkoelkast djkoelkast is offline
Member
 
Join Date: Sep 2006
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Default

ok but I don't see a solution for my problem? I did rename it but next time it will give a new file with a new date again...

httpd -t gives:

Code:
server:~# httpd -t
[Tue Jul 03 10:16:29 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
Syntax OK
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Add email and default website to main domain fbnewtz Installation/Configuration 1 12th June 2007 08:18
can't make work joomla + sef + .htaccess bochenn General 9 4th April 2007 13:47
add cronjob to run a page on a website md@waw.co.uk Programming/Scripts 5 22nd March 2007 23:12
"Shared IP" page again - why? bmwpingvinen Installation/Configuration 6 31st January 2007 14:35
"Shared IP" Message and Fragmented Vhost.conf files! bpmee Installation/Configuration 6 23rd September 2006 22:37


All times are GMT +2. The time now is 18:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.