#1  
Old 23rd November 2005, 20:57
n!x n!x is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL installing problem

I'm following this guide (which is great stuff), but I'm having a problem with the MySQL section.

When I run "netstat -tap" I see this line:

Code:
tcp        0      0 *:mysql                 *:*                     LISTEN     -
I don't get the "2449/mysqld" as the last thing, but only a "-".
My "skip-networking" thing in "/etc/mysql/my.cnf" i commented out and MySQL restartet - but the same thing is in "netstat -tap".

Anyone has a suggestion?
Reply With Quote
Sponsored Links
  #2  
Old 23rd November 2005, 21:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Quote:
Originally Posted by n!x
I'm following this guide (which is great stuff), but I'm having a problem with the MySQL section.

When I run "netstat -tap" I see this line:

Code:
tcp        0      0 *:mysql                 *:*                     LISTEN     -
I don't get the "2449/mysqld" as the last thing, but only a "-".
My "skip-networking" thing in "/etc/mysql/my.cnf" i commented out and MySQL restartet - but the same thing is in "netstat -tap".

Anyone has a suggestion?
Thats OK, if you dont encounter any other problems.

Till
Reply With Quote
  #3  
Old 23rd November 2005, 21:59
n!x n!x is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, but shouldn't MySQL listen on a specific port?
Reply With Quote
  #4  
Old 23rd November 2005, 22:11
n!x n!x is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, now I get another problem.

When I try this:

Code:
sudo echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf
I get a:

Code:
-bash: /etc/postfix/sasl/smtpd.conf: Permission denied
Reply With Quote
  #5  
Old 23rd November 2005, 23:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Dont use sudo, you must login as root user! All steps in the howto must be done as root user.
Reply With Quote
  #6  
Old 23rd November 2005, 23:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Quote:
Originally Posted by n!x
Ok, but shouldn't MySQL listen on a specific port?
MySQL listens on a specific port:

*:mysql

means that it listens on all available IP's on the mysql port.
Reply With Quote
  #7  
Old 24th November 2005, 09:35
n!x n!x is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok thanks till!!

I now ran into trouble again.

When I run the "telnet localhost 25" it only shows:

Code:
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 server.example.com ESMTP Postfix (Ubuntu)
And nothing more happens..... It times out.

Anyone? I really need help...

/n!x
Reply With Quote
  #8  
Old 24th November 2005, 09:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Have you entered:

ehlo localhost

and hit return?

Quote:
After you have established the connection to your postfix mail server type

ehlo localhost

If you see the lines

250-STARTTLS

and

250-AUTH

everything is fine.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL problem on install badben Installation/Configuration 12 20th December 2005 12:59
MySQL connection problem cartdev Installation/Configuration 17 17th November 2005 22:30
SUSE 10.0. x86-64 mysql problem hobit007 Installation/Configuration 2 21st October 2005 16:51
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
Mysql Problem Adding adamluz General 2 20th September 2005 09:33


All times are GMT +2. The time now is 11:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.