Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th June 2007, 16:31
Salvis Salvis is offline
Junior Member
 
Join Date: May 2006
Location: Riga, Latvia
Posts: 26
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via Skype™ to Salvis
Question Apache exit signal Segmentation fault (11) - PHP - Blank page

Hello!

I upgraded my system from Fedora 5 to Fedora 6 (x86_64) using this: http://www.ioncannon.net/system-admi...-fc6-with-yum/
i updated all software via yum update
Now httpd (x86_64 2.2.4-2.fc6) not showing PHP pages. PHP is installed: php x86_64 5.1.6-3.6.fc6

Error log shows:
Quote:
[Wed Jun 13 17:22:43 2007] [notice] child pid 4998 exit signal Segmentation fault (11)
[Wed Jun 13 17:22:52 2007] [error] an unknown filter was not added: PHP
[Wed Jun 13 17:22:52 2007] [error] an unknown filter was not added: PHP
[Wed Jun 13 17:22:53 2007] [notice] child pid 5004 exit signal Segmentation fault (11)
[Wed Jun 13 17:22:55 2007] [error] an unknown filter was not added: PHP
[Wed Jun 13 17:22:55 2007] [error] an unknown filter was not added: PHP
[Wed Jun 13 17:22:56 2007] [notice] child pid 5007 exit signal Segmentation fault (11)
[Wed Jun 13 17:22:57 2007] [error] an unknown filter was not added: PHP
[Wed Jun 13 17:22:57 2007] [error] an unknown filter was not added: PHP
[Wed Jun 13 17:22:57 2007] [notice] child pid 5012 exit signal Segmentation fault (11)
When i trying to open .php page i see blank page. .html pages showing normal.

I have no idea how to fix it. Please help me.
Reply With Quote
Sponsored Links
  #2  
Old 14th June 2007, 13:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Do you use ISPConfig? If so, take a look here: http://www.howtoforge.com/forums/sho...29&postcount=7
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th June 2007, 21:26
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Exactly same problem. After I changed what falko proposed I get errors:

(9)Bad file descriptor: apr_socket_accept: (client socket)

during reload (when I change something in configuration so apache configuration is reloaded). And after that when I click on some PHP site I get error:

[notice] child pid XXXXX exit signal Segmentation fault (11), possible coredump in /tmp


If I manualy restart apache everything works fine (If I just reload, still get same error).

Any Ideas?
Reply With Quote
  #4  
Old 30th June 2007, 16:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Is there a coredump in the /tmp directory?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th June 2007, 20:59
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Yes, I think so. There are some core.XXXXX files in /tmp directory.
Reply With Quote
  #6  
Old 1st July 2007, 13:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's in the latest one?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58
PHP version... ctroyp Installation/Configuration 102 10th November 2005 13:24


All times are GMT +2. The time now is 22:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.