Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th May 2007, 08:04
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default Can't send mail from ISPConfig box

Greetings,

I'll attempt to explain this as best as possible. I have two domain names. fireflythemud.com and serenity-tech.com which all host their sites fine, I received email outside of the network fine.

Here's the kicker, any email sent from the box will not be received. I've narrowed down the reason. Simply put, my ISP is blocking all outgoing SMTP (port 25) traffic, except for their own mail servers traffic. This means that I can receive on port 25, but I can't send on port 25.

My question is this. Is there ANY way I can have the capability of receiving mail through the mail server box I host, and send mail through the ISP's mail server. Perhaps a configuration of sorts? What might make it more complicated is I have to authenticate all outgoing mail with my ISP with my ISP user name and password(optional, but preferred).

Thank you for the attention, hope to hear from you in the morning.

Demortes
Reply With Quote
Sponsored Links
  #2  
Old 20th May 2007, 11:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,418
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

It is possible to configure your postfix mail server to relay all emails trough the smtp server of your ISP with authentication. There must be some posts about this in the forum but I can not find them currently. Maybe someone else has the links at hand
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th May 2007, 16:12
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default

I think it's fixed... or was.

I tried searching the internet and didn't find anything. I posted here, which Till responded. I never tried the word relay in the search engines... I tried it today, and I found the variable needed, relayhost in main.cf (in my setup, /etc/postfix/main.cf). It didn't explain how to set up authentication for the relay host though.
Reply With Quote
  #4  
Old 20th May 2007, 16:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,418
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Please have a look here:

http://www.howtoforge.com/postfix_re...her_mailserver

I didnt find it this morning because I searched in the forums instead of the howtos
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th May 2007, 19:45
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default

OK, that fixed that, but for some reason when I send mail to a user on my domain, it delivers it locally, not the assigned mail server. I mean, I have it set up for google apps, which maintain my email on both domains. I set up ISPConfig to point to External Mailserver, and it's still delivering locally.

Any insight?
Reply With Quote
  #6  
Old 20th May 2007, 19:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,418
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Please make sure that you set all co-domains to external mailserver too and not only the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
:D All recieved mails goes to the system admin user ??help Mounir Installation/Configuration 8 31st July 2006 12:22
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 03:39
Problem with retrieving mail after using ISPConfig sw33t Installation/Configuration 8 14th May 2006 16:38
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 16:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.