Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th November 2005, 19:22
CorrosionX CorrosionX is offline
Junior Member
 
Join Date: Oct 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Problem receiving mail

Hi there

My isp finally unblocked my port 25 so I'm into setting up the mail server correctly.

My problem is that emails that should be received at anyuser@arconsultant.com are delivered to web3_admin@ptsgroup.ca which is the catch-all address of my main domain (ptsgroup.ca). In fact any email sent to any of my non-main domain all get transfered to that address.

Someone on IRC #postfix told me to add @arconsultant.com to the end of each line of my virtusertable, but that seems unnecessary, lots of people use ISPconfig as is and have no problems.

Can someone help me out with this?

Thanks in advance
Dave
Reply With Quote
Sponsored Links
  #2  
Old 15th November 2005, 20:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,714 Times in 2,556 Posts
Default

Have a look here: http://www.howtoforge.com/faq/13_33_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th November 2005, 20:26
CorrosionX CorrosionX is offline
Junior Member
 
Join Date: Oct 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok mydomain wasn't even in the main.cf file. I had myhostname though and it was www.ptsgroup.ca

If I understand correcly i have to change them to something else than ptsgroup.ca (i used www.ptsweb.ca, which is in my hosts file).

I tried changing a couple of things around but still all mail is delivered to the catch-all of ptsgroup.ca (which is our main domain)
Reply With Quote
  #4  
Old 15th November 2005, 21:02
CorrosionX CorrosionX is offline
Junior Member
 
Join Date: Oct 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I didn't succeed in not having the bug, but at least when I removed the catchall from my address all mail was being distributed nicely.

In case I want the catch-all for my main domain again , what should I do?
Reply With Quote
  #5  
Old 15th November 2005, 21:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,169 Times in 4,053 Posts
Default

Quote:
Originally Posted by CorrosionX
In case I want the catch-all for my main domain again , what should I do?
Use a domain for $mydomain in your main.cf that was not used by a website in ISPConfig. E.g. create a new subdomain like server1.maindomain.com and use this as $mydomain in your main.cf.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
mail problem Mahir Installation/Configuration 16 24th April 2007 20:22
mail problem Mahir Installation/Configuration 1 11th November 2005 12:57
Mail Problem toyito Installation/Configuration 9 8th November 2005 18:15
Mailserver not receiving mail Unsaferanger Installation/Configuration 3 26th August 2005 08:59


All times are GMT +2. The time now is 20:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.