#1  
Old 8th May 2007, 16:50
sinjab sinjab is offline
Junior Member
 
Join Date: Jan 2007
Posts: 21
Thanks: 3
Thanked 1 Time in 1 Post
Default Web-FTP not working

After logging into Web-FTP, it shows empty (both the tree and the list). FileZilla works fine and shows the home directory.

How to fix this problem?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 9th May 2007, 10:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

How large is the website and how many files does it contain approx? The WebFTP is not able to load if your website contains several thousand files and directories.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th May 2007, 11:20
sinjab sinjab is offline
Junior Member
 
Join Date: Jan 2007
Posts: 21
Thanks: 3
Thanked 1 Time in 1 Post
Default

Web-FTP is not working with all sites. Even with newly created ones which contain a few files and directories created by ISPConfig by default. I think this problem happened after updating to ISPConfig 2.2.12.

Thanks
Reply With Quote
  #4  
Old 10th May 2007, 18:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Are there any error messages in the error log in /root/ispconfig/httpd/logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th May 2007, 13:18
sinjab sinjab is offline
Junior Member
 
Join Date: Jan 2007
Posts: 21
Thanks: 3
Thanked 1 Time in 1 Post
Default

I've just reupdated to ISPConfig 2.2.12 and the problem still there.

The content of error_log is:
Quote:
[Fri May 11 13:11:55 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
[Fri May 11 13:11:55 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Fri May 11 13:15:17 2007] [notice] caught SIGTERM, shutting down
[Fri May 11 13:15:24 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
[Fri May 11 13:15:24 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
The content of access_log is:
Quote:
82.137.200.18 - - [11/May/2007:13:16:03 +0300] "GET /login.php HTTP/1.0" 200 2398
82.137.200.18 - - [11/May/2007:13:16:06 +0300] "POST /login/login.php HTTP/1.0" 200 107
82.137.200.18 - - [11/May/2007:13:16:08 +0300] "GET /login/trylogin.php?v= HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:08 +0300] "GET /index.php? HTTP/1.0" 200 1553
82.137.200.18 - - [11/May/2007:13:16:09 +0300] "GET /isp_manager/navigation.php? HTTP/1.0" 200 7936
82.137.200.18 - - [11/May/2007:13:16:10 +0300] "GET /isp_manager/inhalt_tree.php? HTTP/1.0" 200 28992
82.137.200.18 - - [11/May/2007:13:16:10 +0300] "GET /isp_manager/frame_start.php? HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:10 +0300] "GET /isp_manager/legende.php? HTTP/1.0" 200 361
82.137.200.18 - - [11/May/2007:13:16:12 +0300] "GET /multidoc/edit/edit.php?doc_id=3&doctype_id=1021& HTTP/1.0" 200 12358
82.137.200.18 - - [11/May/2007:13:16:13 +0300] "GET /isp_manager/vorladen.php? HTTP/1.0" 200 557
82.137.200.18 - - [11/May/2007:13:16:13 +0300] "GET /isp_manager/placeholder.php? HTTP/1.0" 200 297
82.137.200.18 - - [11/May/2007:13:16:20 +0300] "GET /capp.php?app=isp_file HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:21 +0300] "GET /index.php? HTTP/1.0" 200 1541
82.137.200.18 - - [11/May/2007:13:16:22 +0300] "GET /isp_file/navigation.php? HTTP/1.0" 200 4933
82.137.200.18 - - [11/May/2007:13:16:23 +0300] "GET /isp_file/inhalt_tree.php? HTTP/1.0" 200 18152
82.137.200.18 - - [11/May/2007:13:16:23 +0300] "GET /isp_file/frame_start.php? HTTP/1.0" 200 3399
82.137.200.18 - - [11/May/2007:13:16:23 +0300] "GET /isp_file/legende.php? HTTP/1.0" 200 361
82.137.200.18 - - [11/May/2007:13:16:25 +0300] "GET /isp_file/vorladen.php? HTTP/1.0" 200 1116
82.137.200.18 - - [11/May/2007:13:16:25 +0300] "GET /isp_file/placeholder.php? HTTP/1.0" 200 297
82.137.200.18 - - [11/May/2007:13:16:28 +0300] "POST /isp_file/frame_start.php? HTTP/1.0" 200 3399
82.137.200.18 - - [11/May/2007:13:16:31 +0300] "POST /isp_file/frame_start.php? HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:32 +0300] "GET /index.php? HTTP/1.0" 200 1541
82.137.200.18 - - [11/May/2007:13:16:33 +0300] "GET /index.php? HTTP/1.0" 200 1541
82.137.200.18 - - [11/May/2007:13:16:34 +0300] "GET /isp_file/navigation.php? HTTP/1.0" 200 6632
82.137.200.18 - - [11/May/2007:13:16:35 +0300] "GET /isp_file/inhalt_tree.php? HTTP/1.0" 200 18153
82.137.200.18 - - [11/May/2007:13:16:35 +0300] "GET /isp_file/frame_start.php? HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:35 +0300] "GET /isp_file/legende.php? HTTP/1.0" 200 361
82.137.200.18 - - [11/May/2007:13:16:37 +0300] "GET /isp_file/edit/ordner.php?&ordner=root&web_id=19 HTTP/1.0" 200 3029
82.137.200.18 - - [11/May/2007:13:16:37 +0300] "GET /isp_file/vorladen.php? HTTP/1.0" 200 1116
82.137.200.18 - - [11/May/2007:13:16:37 +0300] "GET /isp_file/placeholder.php? HTTP/1.0" 200 297

However, when doing /etc/init.d/ispconfig_server restart I get:
Quote:
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/root/ispconfig/httpd/bin/apachectl stop: httpd stopped
ISPConfig system stopped!
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
ISPConfig system is now up and running!
Thanks

Last edited by sinjab; 11th May 2007 at 13:21.
Reply With Quote
  #6  
Old 11th May 2007, 22:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

There are no errors in the logs. You got the errors on ISPConfig restart because you executed the start / stop script from within a non existant directory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP not working mimic General 4 21st August 2006 16:21
FTP Not working mphayesuk General 16 11th May 2006 01:09
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
ftp not working mwebb Installation/Configuration 4 10th January 2006 21:41
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 02:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.