#1  
Old 5th April 2007, 20:41
wapa17 wapa17 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 28
Thanks: 2
Thanked 3 Times in 3 Posts
Question FTP doesnt work more..

I installed ISPConfig in November 2006 (Mandrake 2006 - perfect setup).
Well - some mail and DNS related issues but this has been solved manually ;-)

Then I decided to install a CRON-job to look for updates automatically....and here began the trouble: I cannot login into FTP more (neither via ISPConfig-Admin nor with a FTP-Client).
It has something to do with the "auto-update" (I have it disabled now).
Well, it looks like if I have to downgrade the ProFTP.

My question is: HOW to downgrade without to break the ISPConfig - configuration ?
Reply With Quote
Sponsored Links
  #2  
Old 6th April 2007, 11:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,414
Thanks: 812
Thanked 5,204 Times in 4,080 Posts
Default

I think its not nescessary to downgrade proftpd as all proftpd versions should be compatible with ISPConfig.

Please have a look if your last proftpd update has replaced the proftpd.conf file and left a copy of the old configuration in the same directory which you can compare to the new config.

Please post the output of:

netstat -tap | grep ftp

and

ps aux | grep ftp
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th April 2007, 16:08
wapa17 wapa17 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 28
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Hi Till,

thanks for your answer.
The outputs are:
--------------- cut -----------------
> netstat -tap | grep ftp
tcp 0 0 *:ftp *:* LISTEN 29701/proftpd: (acc


and

> ps aux | grep ftp
nobody 29701 0.0 0.5 5660 2580 ? Ss Apr08 0:00 proftpd: (accepting connections)
root 11928 0.0 0.2 2204 1024 ? R 09:05 0:00 sh -c (ps aux | grep ftp) 2>&1
root 11929 0.0 0.2 2204 1040 ? R 09:05 0:00 sh -c (ps aux | grep ftp) 2>&1

------------- cut ------------------

It seems, that the command netstat -tap | grep ftp outputs incomplete data ..
Reply With Quote
  #4  
Old 10th April 2007, 15:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by wapa17
It seems, that the command netstat -tap | grep ftp outputs incomplete data ..
That's normal.
FTP seems to be running.
Is FTP allowed in the firewall? What's the output of
Code:
iptables -L
? Are there any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th April 2007, 18:20
wapa17 wapa17 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 28
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Output of Iptables -L
--------------------- cut ----------------------
> iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
------------------------ cut ------------------------------

and yes. ftp is allowed in the firewall ... and it was running before very well, but now I cannot more access FTP neither outside nor locally (and this has something to do with the auto-update..).

Sometimes I have a strange log in syslog:
-------------- cut --------------------
Apr 10 10:30:00 mail proftpd[8538]: mail.myname.net (mail.myname.net [127.0.0.1]) - FTP session opened.
Apr 10 10:30:00 mail proftpd[8538]: mail.myname.net (mail.myname.net [127.0.0.1]) - invalid CommandBufferSize size (0) given, resetting to default buffer size (512)
Apr 10 10:30:00 mail proftpd[8538]: mail.myname.net (mail.myname.net [127.0.0.1]) - FTP session closed.
----------------cut -----------------------
Reply With Quote
  #6  
Old 11th April 2007, 16:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by wapa17
Apr 10 10:30:00 mail proftpd[8538]: mail.myname.net (mail.myname.net [127.0.0.1]) - invalid CommandBufferSize size (0) given, resetting to default buffer size (512)
What's in /etc/proftpd.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP won't work correctly ;-/ LeoLinux Installation/Configuration 6 28th November 2006 22:00
ftp problems tgansert Installation/Configuration 20 27th May 2006 19:06
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
Website users? ctroyp General 25 6th January 2006 18:02
FTP 101 the basics koegies Installation/Configuration 7 17th November 2005 15:55


All times are GMT +2. The time now is 10:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.