Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th November 2005, 20:38
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Cool FTP access to web files in ISPConfig

I've set up Debian Sarge 3.1(Perfect Setup) with ISPConfig successfully. However, I'm wondering if there is anyway to get FTP access to the web files for the site I've created.

I've given the user administrator and shell access rights. When I log into the FTP server, it shows me a list of folders, includnig the web folder. When i edit the index.html file and upload it to the FTP server, it still brings up the default page. Could it be that this is not the web file location? When i visit my website, it gives me http://domain.tld/apache2-default/ in the lcation bar.

Also, i noticed that when a user is created, it creates a home folder with a user website. I cannot access that site either. I tried http://www.domain.tld/user/ and http://www.domain.tld/users/user/ but it doesn't work. It gives me an Object Not Found error.
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2005, 21:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Rocky
I've given the user administrator and shell access rights. When I log into the FTP server, it shows me a list of folders, includnig the web folder. When i edit the index.html file and upload it to the FTP server, it still brings up the default page. Could it be that this is not the web file location? When i visit my website, it gives me http://domain.tld/apache2-default/ in the lcation bar.
What's in /etc/apache2/sites-enabled?

Quote:
Originally Posted by Rocky
Also, i noticed that when a user is created, it creates a home folder with a user website. I cannot access that site either. I tried http://www.domain.tld/user/ and http://www.domain.tld/users/user/ but it doesn't work. It gives me an Object Not Found error.
It's either www.domain.tld/users/<username> or www.domain.tld/~<username>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th November 2005, 21:30
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Below is the content of the file found in the /etc/apache2/sites-enabled folder.

File name:
000-default

Content:
NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>
Reply With Quote
  #4  
Old 7th November 2005, 22:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Can you delete that symlink (it should be a symlink to a real file, not a file itself) and restart Apache?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th November 2005, 22:11
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Do you mean delete the file 000-default?
Reply With Quote
  #6  
Old 7th November 2005, 22:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Rocky
Do you mean delete the file 000-default?
Yes, right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Issues - Access Forbidden! rytech Installation/Configuration 23 22nd June 2006 15:25
FTP access with Dreamweaver / FTPclient pjm2211 Installation/Configuration 17 1st November 2005 23:31
FTP access problem... ctroyp General 7 12th October 2005 17:07
FTP access? ctroyp Installation/Configuration 14 29th September 2005 17:26
Access Denied on Port: 81 nandhu Installation/Configuration 2 10th August 2005 14:05


All times are GMT +2. The time now is 19:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.