Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th March 2007, 16:07
zimele zimele is offline
Member
 
Join Date: Jun 2006
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Question ISPConfig and AWStats

Hi All


Can you please assist me with the installation of AWStats on my ISPConfig server cause i tried to do the installation from the ispconfig website and i ran the task but somehow i still can't logon to the statistics on any of the websites on my server


can you please give me a breakdown on what to do and when i'm done how to get the statistics of the different website


Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 24th March 2007, 17:56
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Which AWstats are you using? I know the one from djtremors (dynamic pages) gets updated at night, so you're only able to see stats after the first night.

Don't know about the static awstats version, which is the default reference on the ISPConfig site.
Reply With Quote
  #3  
Old 24th March 2007, 19:07
vogelor vogelor is offline
ISPConfig Developer
 
Join Date: Jan 2007
Location: Wernau, Germany
Posts: 219
Thanks: 42
Thanked 34 Times in 24 Posts
Default

1) look, if the awstats directory exists
2) check if the statistik-checkbox is checked inside ISPConfig (for the web you need)
3) try to login with the user of the web (admin or the company's login will not work). you need to login as web[n]_[name]
__________________
Der neue Luxus heit Zeit, nicht Geld!

Firma : http://www.muv.com, http://www.computerandservice.de
Privat : http://www.vogelor.de
Reply With Quote
  #4  
Old 25th March 2007, 00:12
zimele zimele is offline
Member
 
Join Date: Jun 2006
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Default AWStats Installation

I Should think that the statistik option is enabled cause i am to get my stats from webalizer and my problem is that i have gone through the steps that are given in the ISPConfig website and my question is after this what do i have to do

Beta 1 is just a repackage of Alpha 8, because there where no known Bugs for a long time
If you are still interested go on and test the installer ISPConfig_awstats_pkg_beta-1.tar.gz. Follow theses Steps:

Become root

code:
su -
Change directory

code:
cd /usr/src
Download the archive

code:
wget http://jnsc.ch/downloads/ISPConfig_a..._beta-1.tar.gz
Extract the archive

code:
tar -xvzf ISPConfig_awstats_pkg_beta-1.tar.gz
Change directory

code:
cd ISPConfig_awstats_pkg
Install

code:
./install.sh
This step is optional, it will generate the statistics. But you could also wait until the cron is executed (4:00 am)

code:
/root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php
That's it.


after this what do i have to do to enable AWStats to get stats for my websites and how would i go by reviewing these stats

Hope my response helps solve my problem thanks again

Last edited by jnsc; 6th November 2008 at 16:08. Reason: changed link
Reply With Quote
  #5  
Old 25th March 2007, 12:34
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 531
Thanks: 11
Thanked 175 Times in 79 Posts
Default

If you did all this steps you should be able to go to http://www.mysite.com/awstats (the username and the password are the same as for webalizer). If you get an error please check that you have files in the awstats directory of your website.

Regards Jonas
Reply With Quote
  #6  
Old 28th March 2007, 13:06
zimele zimele is offline
Member
 
Join Date: Jun 2006
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Default AWStats still no luck!!

Hi

i've had a look at the contents on my website and there is no awstats directory there is only the webalizer (stats) directory and the content of one and when AWStats is installed properly will it have the same stats as webalizer or will my stats start at 0
Reply With Quote
  #7  
Old 28th March 2007, 13:11
vogelor vogelor is offline
ISPConfig Developer
 
Join Date: Jan 2007
Location: Wernau, Germany
Posts: 219
Thanks: 42
Thanked 34 Times in 24 Posts
Default

Quote:
Originally Posted by zimele
Hi

i've had a look at the contents on my website and there is no awstats directory there is only the webalizer (stats) directory and the content of one and when AWStats is installed properly will it have the same stats as webalizer or will my stats start at 0
sorry - don't know.
the only thing i know is that awstats "regenerated" the log i lost for 5 days.
But i don't know how long it regenerates the log.
__________________
Der neue Luxus heit Zeit, nicht Geld!

Firma : http://www.muv.com, http://www.computerandservice.de
Privat : http://www.vogelor.de
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Awstats for ispconfig feanor Installation/Configuration 26 23rd February 2009 20:14
ISPConfig Roadmap till Developers' Forum 26 10th June 2007 23:38
Another Awstats Configuration Thingy For ISPConfig asyadiqin Installation/Configuration 2 6th August 2006 14:20
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 16th May 2006 00:04
ISPConfig security Joffar Installation/Configuration 18 4th March 2006 04:49


All times are GMT +2. The time now is 10:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.