#1  
Old 8th March 2007, 08:31
brainz brainz is offline
Senior Member
 
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 165
Thanks: 9
Thanked 3 Times in 1 Post
Default DNS - named will not start ??

Hi till and falko

The dns named will not start.... when i try to restart it this is what i get..

Quote:
etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found
help please

regards
brainz
__________________
www.baktim.com
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2007, 08:33
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,394
Thanks: 833
Thanked 5,488 Times in 4,320 Posts
Default

Please post the content of the file /root/ispconfig/isp/conf/named.conf.master
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th March 2007, 08:36
brainz brainz is offline
Senior Member
 
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 165
Thanks: 9
Thanked 3 Times in 1 Post
Default

As Requested till,

Here is the content of /root/ispconfig/isp/conf/named.conf.master

Quote:
options { pid-file "/var/named/chroot/var/run/named/named.pid"; directory "{BINDDIR}"; auth-nxdomain no; /* * If there is a firewall between you and nameservers you want * to talk to, you might need to uncomment the query-source * directive below. Previous versions of BIND always asked * questions using port 53, but BIND 8.1 uses an unprivileged * port by default. */ // query-source address * port 53; }; // // a caching only nameserver config // zone "." { type hint; file "named.ca"; }; zone "0.0.127.in-addr.arpa" { type master; file "named.local"; }; zone "{ZONE}.in-addr.arpa" { type master; file "pri.{ZONE}.in-addr.arpa"; }; zone "{DOMAIN}" { type master; file "pri.{DOMAIN}"; }; zone "{DOMAIN}" { type slave; file "sec.{DOMAIN}"; masters { {MASTERS}; }; }; //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////
till also i get this.. which maybe a clue...
Quote:
rndc: connect failed: 127.0.0.1#953: connection refused
regards
brainz
__________________
www.baktim.com

Last edited by brainz; 8th March 2007 at 08:41.
Reply With Quote
  #4  
Old 8th March 2007, 08:46
brainz brainz is offline
Senior Member
 
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 165
Thanks: 9
Thanked 3 Times in 1 Post
Default

Hi till

i also get this as a email from the server as well

Quote:
WARNING: service dns not running (server: domain.com, port: 53)!

WARNING: service dns not running (server: domain.com, port: 53)!

WARNING: service not running (server: domain.com, port: 10000)!
regards
brainz
__________________
www.baktim.com

Last edited by brainz; 30th September 2008 at 09:36.
Reply With Quote
  #5  
Old 8th March 2007, 09:20
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Originally Posted by brainz
Hi till

i also get this as a email from the server as well



regards
brainz
That's because the mailserver and probably spamassassin use DNS for various checks. It will go away when you fixed your DNS.
Is the output you posted for /root/ispconfig/isp/conf/named.conf.master really like that? No new lines?
Reply With Quote
  #6  
Old 8th March 2007, 10:05
brainz brainz is offline
Senior Member
 
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 165
Thanks: 9
Thanked 3 Times in 1 Post
Default

Im sorry but yes there are no new lines
__________________
www.baktim.com
Reply With Quote
  #7  
Old 13th June 2010, 20:53
cvgeeks cvgeeks is offline
Member
 
Join Date: Mar 2010
Posts: 48
Thanks: 1
Thanked 7 Times in 6 Posts
Talking Error in dns

I too had this problem except in my situation the problem started after I removed the IP address in the " IP LIST" Field. Once I removed my secondary IP and rebooted the server named was nolonger running.

I went through the items listed in this thread seeing if any of them applied to my situation and heres what I found:

1. In ISPCONFIG under "Management" "Server" "Settings" on the "DNS" tab in zone files directory it was listed wrong it was showing: /home/admispconfig/ispconfig/web/multidoc/edit
and I knew that it needed to be:
/var/named/chroot/var/named
however no matter how many times I tried it would not stick! So I rememberd that when I was going through the process of adding my second IP I turned "Automatic Networking" on. and I turned NetworkManager off. So I reveresed the process restarted the server went back into ISPCONFIG and changed my DNS DIR back to its original and this time it stuck!
Then I created an entry in my dns and it stuck as well. Then I restarted named and it stayed on.

Problem solved: I hope this helps someone troubleshooting their issue in the future.
Reply With Quote
The Following User Says Thank You to cvgeeks For This Useful Post:
falko (14th June 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error Hellbound General 4 7th January 2007 11:50
Named crashing every 20 min RingofFire Installation/Configuration 4 23rd November 2006 02:39
BIND broke adamluz Installation/Configuration 4 2nd June 2006 21:31
Please explain Bind, named, NameServer, DNS domino HOWTO-Related Questions 7 22nd August 2005 10:18


All times are GMT +2. The time now is 18:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.