Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd February 2007, 23:30
wheatie wheatie is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Problems with clamscan after upgrading to ISPConfig-2.2.10

Accidently posted this in the wrong form so here I am posting it again :-)


After upgrading I am now getting the following email headers on all inbound
emails. Unable to find anything usefull in server logs...


X-Virus-Status: Failed
X-Virus-Report: /home/admispconfig/ispconfig/tools/clamav/bin/clamscan error 40
X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.90/2631/Thu Feb 22 15:33:11 2007

After googling i've found the following info..

http://www.gossamer-threads.com/list...av/users/29150


I guess my questions is... will following those instructions fix this issue, and is this a common or known problem.
Reply With Quote
Sponsored Links
  #2  
Old 23rd February 2007, 11:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,972
Thanks: 825
Thanked 5,367 Times in 4,214 Posts
Default

Please try the instructions if they fix your problem and report back. I have not heard of the probelm yet.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd February 2007, 12:47
porjo porjo is offline
Junior Member
 
Join Date: Nov 2006
Location: Australia
Posts: 15
Thanks: 0
Thanked 2 Times in 1 Post
Default

I was getting that identical error also.

I followed the instruction in the google link about changing the clamassassin file i.e:

File /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin

CLAMSCANOPT="--no-summary --stdout --mbox"

Change this to:

CLAMSCANOPT="--no-summary --stdout"


That appears to have fixed the issue. My email header now shows:

X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.90/2631/Thu Feb 22 16:33:11 2007
Status: O
Reply With Quote
  #4  
Old 23rd February 2007, 15:11
wheatie wheatie is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes this does appear to fix the issue.
Reply With Quote
  #5  
Old 24th February 2007, 10:09
Herbert Herbert is offline
Member
 
Join Date: May 2006
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here the same problem, i fixed the bug.
Reply With Quote
  #6  
Old 24th February 2007, 10:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,972
Thanks: 825
Thanked 5,367 Times in 4,214 Posts
Default

I will make a official patch for this. It looks as the clamassassin devs know the problem, but they havent released a new version yet.

I really dont know why the clamav guys let a operation fail when a commandline option is added that was valid in the prior version of clamav instead of giving a deprecated message
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 24th February 2007 at 10:30.
Reply With Quote
  #7  
Old 24th February 2007, 11:08
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Smile

Within /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin i changed that line too. After changing, I can confirm that it is working indeed.

Thanks for the info!
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig on Ubuntu: Upgrading Breezy to Dapper Clogboy General 6 22nd February 2007 21:32
Ispconfig update problems from 2.4 to 2.6 adrenalinic Installation/Configuration 23 7th September 2006 12:58
Upgrading failed, ispconfig broken and ispconfig won't upgrade again dfriis Installation/Configuration 7 14th June 2006 17:54
Users and websites aren't created Glorfindel Installation/Configuration 9 23rd February 2006 04:20


All times are GMT +2. The time now is 12:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.