Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st November 2005, 16:29
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default DNS issue and user's alias problem

Everything seemed to be OK BEFORE I Installed ISPConfig:

My domain name is test1.com. Originally I used /etc/httpd/conf/httpd.conf to define a website:
.
ServerName www.tabxx1.com :80
DocumentRoot /var/www/html
.
<VirtualHost 203.xxx.xxx.xxx:80>
.
ServerName www.stkxx1.com :80
DocumentRoot /home/~user/public
.
</VirtualHost>

DNS server at dns.tabxx1.com had already setup without fail.

========
AFTER I installed ISPConfig,I used DNS Manager in ISPConfig to create 2 master DNS for both tabxx1.com and stkxx1.com, then related A record such as:

mater DNS SOA: dns.tabxx1.com
203.xxx.xxx.xxx dns.tabxx1.com
203.xxx.xxx.xxx www.tabxx1.com
203.xxx.xxx.xxx mail.tabxx1.com

mater DNS SOA: dns.tabxx1.com
203.xxx.xxx.xxx www.stkxx1.com
203.xxx.xxx.xxx mail.stkxx1.com

And I have created a client "Stock1" and a web site at "www.stkxx1.com".
administraor of this site is called "web1_abc".

Here are my problems:

1) the original DocumentRoot of www.tabxx1.com had been changed from /var/www/html to /home/www/web.

2) If I copy the original webpages from /var/www/html to /home/www/web, both http://www.tabxx1.com and http://www.stkxx1.com will display the same homepage-index.htm.

How can I use /var/www/html as DocumentRoot of www.tabxx1.com and use /home/www/user/web1_abc/web as DocumentRoot of www.stkxx1.com?

3)I have tried to forward http://www.stkxx1.com to http://www.tabxx1.com.tw/~web1_abc, but the following error occured:
"The domain forward contained invalid signs and has therefore been deleted."

There must be something wrong with my DNS settings in ISPConfig. I didn't setup any CNAME in DNS Manager. Does it matter? I am not using any router right now. Can anyone of you may point out what I should do to correct the error?
Reply With Quote
Sponsored Links
  #2  
Old 1st November 2005, 16:32
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default

Oops! Sorry. My domain name is supposed to be tabxx1.com instead of test1.com.
Reply With Quote
  #3  
Old 1st November 2005, 16:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Quote:
Originally Posted by rosa hsiao
1) the original DocumentRoot of www.tabxx1.com had been changed from /var/www/html to /home/www/web.
Thats normal. But the document root has not been changed to /home/www/web, it has changed to /home/www/www.tabxx1.com/web

Quote:
2) If I copy the original webpages from /var/www/html to /home/www/web, both http://www.tabxx1.com and http://www.stkxx1.com will display the same homepage-index.htm.
Copy the contents to the new home directories:

/home/www/www.tabxx1.com/web/

and

/home/www/www.stkxx1.com/web/

Quote:
How can I use /var/www/html as DocumentRoot of www.tabxx1.com and use /home/www/user/web1_abc/web as DocumentRoot of www.stkxx1.com?
You can but its not recommended. If you want to use it you will have to setup namebased vhosts manually in your httpd.conf.

Quote:
3)I have tried to forward http://www.stkxx1.com to http://www.tabxx1.com.tw/~web1_abc, but the following error occured:
"The domain forward contained invalid signs and has therefore been deleted."
Forwards to user wbs are set automatically. Copy the content you want to reach under the URL http://www.tabxx1.com.tw/~web1_abc to the directory:

/home/www/www.tabxx1.com/user/web1_abc/web/

But why do you need the path http://www.tabxx1.com.tw/~web1_abc ?

Last edited by till; 1st November 2005 at 17:05.
Reply With Quote
  #4  
Old 2nd November 2005, 10:03
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
Thats normal. But the document root has not been changed to /home/www/web, it has changed to /home/www/www.tabxx1.com/web

Copy the contents to the new home directories:

/home/www/www.tabxx1.com/web/

and

/home/www/www.stkxx1.com/web/

?
Quote:
Originally Posted by till
But why do you need the path http://www.tabxx1.com.tw/~web1_abc ?

I have seen only two directories under /home/www:

/home/www/web1 and a symbolic link www.stkxx1.com
/home/www/web2 and a symbolic link www.tabxx1.com

Then I copied two different contents to the new home directories separatedly as you told me.

But when I browsed http://www.tabxx1.com and http://www.stkxx1.com again, the result was strange:

http://www.tabxx1.com displayed the homepages of http://www.stkxx1.com.

http://www.stkxx1.com redirected me to http://www.tabxx1.com/web1_abc with an error message showing that there is no such file in that user's directory.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP access problem... ctroyp General 7 12th October 2005 17:07


All times are GMT +2. The time now is 08:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.