Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st February 2007, 04:30
dutchman dutchman is offline
Junior Member
 
Join Date: Feb 2006
Location: Loveland, OH
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Question Fedora Core 5 Perfect Setup - Postfix problem

I started with my first Linux server with RedHat 9.0. I have Fedora 1.0, 3.0, 4.0 and 5.0 and now I am trying to create my first mail server. I followed the C5 Perfect Setup. I deviated a couple of times and ran into problems so I wiped the disk and this time I followed to the letter. (I think.)

However, I can not get the mail server to accept the mail and deliver it to the users. I am not planning to install ISPConfig so I followed the steps below. and it doesn't work.

If you do not want to install ISPConfig, then you must configure Postfix to deliver emails to a user's Maildir:

postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart

I checked the directories for the users and there is no Maildir in the users directories.

I even tried the following to create a directory to no avail.

echo "hello" | mail root
echo "hello" | mail terry

Nothing!

The rest of the installation was great! Thanks for your efforts!

Here is tha main.cf

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = mmaserver.tlalbright.com
mydomain = tlalbright.com
myorigin = $mydomain
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2007, 11:51
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

The Maildir will be created when the first email is delivered.

If you perform an telnet session from your desktop pc to your mailserver IP-address, like:

ehlo IP-address 25

What do you see then?
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
  #3  
Old 21st February 2007, 13:14
dutchman dutchman is offline
Junior Member
 
Join Date: Feb 2006
Location: Loveland, OH
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Tried this

I tried the following

ehlo 192.168.1.200 25 (The IP of the server)

From the server I tried

echo "hello" | mail root
echo "hello" | mail terry

and I sent an email from hotmail.com to

my server.

No mail shows up for root or terry

No Maildir shows up in the directories for root or terry

The hotmail message returns with 5 minutes as a failed to deliver.

I restarted the postfix, saslauthd, and dovecot this morning.

I got the following entry in the message file.

Feb 21 06:44:16 mmaserver saslauthd[22666]: server_exit : master exited: 22666
Feb 21 06:44:17 mmaserver saslauthd[27296]: detach_tty : master pid is: 27296
Feb 21 06:44:17 mmaserver saslauthd[27296]: ipc_init : listening on socket: /var/run/saslauthd/mux

The hotmail message created the following entry in the maillog file.

Feb 21 06:58:37 mmaserver postfix/smtpd[27429]: NOQUEUE: reject: RCPT from bay0-omc3-s22.bay0.hotmail.com[65.54.246.222]: 554 <terry@tlalbright.com>: Relay access denied; from=<myhotmailaccount@hotmail.com> to=<terry@tlalbright.com> proto=ESMTP helo=<bay0-omc3-s22.bay0.hotmail.com>
Reply With Quote
  #4  
Old 21st February 2007, 23:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by dutchman
Feb 21 06:58:37 mmaserver postfix/smtpd[27429]: NOQUEUE: reject: RCPT from bay0-omc3-s22.bay0.hotmail.com[65.54.246.222]: 554 <terry@tlalbright.com>: Relay access denied; from=<myhotmailaccount@hotmail.com> to=<terry@tlalbright.com> proto=ESMTP helo=<bay0-omc3-s22.bay0.hotmail.com>
You must add all domains that you want to receive emails for to the mydestination parameter in /etc/postfix/main.cf.
Also take a look here: http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd February 2007, 04:30
dutchman dutchman is offline
Junior Member
 
Join Date: Feb 2006
Location: Loveland, OH
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Almost got it!

Thanks for the last gerat bit of info. I am now sending and receiving mail. I have just one last problem.

When I send mail it puts localhost.domainname as the origin. Consequently, when someone replies, I never get it because it has localhost in front of the domain name and there is no valid address for that domain.

I had the following in my main.cf file (see above)

myhostname = mmaserver.tlalbright.com
mydomain = tlalbright.com
myorigin = $mydomain

I changed it to

myorigin = /etc/mailname

and put

tlalbright.com

in the file mailname.

I keep getting the same thing for an address

terry@localhost.tlalbright.com

Any last suggeestions. I do greatly appreciate the help.
Reply With Quote
  #6  
Old 24th February 2007, 14:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Did you specify the correct sender address in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup - Fedora Core 4 british.assassin Server Operation 9 21st February 2008 17:29
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Perfect Setup - Fedora Core 4 - postfix problem Median Installation/Configuration 7 2nd February 2006 12:21
Perfect Setup - Fedora Core 3 - saslauthd problem Median Installation/Configuration 28 29th January 2006 18:51


All times are GMT +2. The time now is 16:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.