Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th February 2007, 03:28
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default Email Questions & Problem

Thanks for the help in advance, I have been searching the forums, but haven't found anything posted yet. I am rebuilding my web server using the Perfect Ubuntu 6.10 setup. I have it installed successfully (to my knowledge). Anyway, here goes the questions:

1. When an email is sent out via a hosted domain, when I receive the email, it will literally say "web7_corey@example.com" instead of "web7_corey@myrealdomain.com". So when I reply to the message, it won't get delivered. I have checked the local-host-names, main.cf, virtusertables, hosts, checked my hostname, etc. Any thing I am missing?

2. As with the email address above, am I able to remove the web7_ that is preceeding the email address? So it would just be corey@myrealdomain.com?

3. Can I add users for email to the hostingdomain.com site? Or do I have to create a hosted site?

Thanks,

Corey
Reply With Quote
Sponsored Links
  #2  
Old 7th February 2007, 19:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by koltz
1. When an email is sent out via a hosted domain, when I receive the email, it will literally say "web7_corey@example.com" instead of "web7_corey@myrealdomain.com". So when I reply to the message, it won't get delivered. I have checked the local-host-names, main.cf, virtusertables, hosts, checked my hostname, etc. Any thing I am missing?
You must set the correct sender address in your email client.

Quote:
Originally Posted by koltz
2. As with the email address above, am I able to remove the web7_ that is preceeding the email address? So it would just be corey@myrealdomain.com?
See above.

Quote:
Originally Posted by koltz
3. Can I add users for email to the hostingdomain.com site? Or do I have to create a hosted site?
You must create a web site hostingdomain.com in ISPConfig, and then you can add email accounts on the User & Email tab.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th February 2007, 23:13
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default

This is through SquirrelMail for sending. I figured out how to change the names by eliminate the preceeding web(number) in the ISPConfig, but mostly right now is just the username@example.com that it is being sent from. The username is correct, it is when a user replies, it is replying to "example.com".

Corey
Reply With Quote
  #4  
Old 8th February 2007, 10:10
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

The 'Reply-To' header is created by the client you used to create the original e-mail. Please have a look at the client settings originating the mail.
Reply With Quote
  #5  
Old 22nd February 2007, 22:46
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default Same problem

You people can't read, can you. He's saying, the problem is with squirrelmail and not an email client like Outlook.

I have the same problem with e-mails sent from squirrelmail, well sort of. The from address, when the email is received, is <domain>.nl_<username>@<mailserverdomain>.nl and not <username>@<domain>.nl

Anybody knows what the problem is? I can't find it.

Ps. And please don't tell me every client who has an email account with us has to set his personal settings. I've used vpostmaster and never had that problem before. They also used squirrelmail.
But if so, is there a way that the user MUST set his personal settings when logging on for the first time?

Last edited by rvarkevisser; 22nd February 2007 at 22:53.
Reply With Quote
  #6  
Old 23rd February 2007, 17:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by rvarkevisser
You people can't read, can you. He's saying, the problem is with squirrelmail and not an email client like Outlook.
Squirrelmail is an email client, just as Outlook is.

Quote:
Originally Posted by rvarkevisser
Ps. And please don't tell me every client who has an email account with us has to set his personal settings.
That's the way it is. If your clients used Outlook instead of Squirrelmail, they'd have to do the same.

Quote:
Originally Posted by rvarkevisser
I've used vpostmaster and never had that problem before. They also used squirrelmail.
Maybe on a setup with virtual users where the username is the email address? That's a totally different setup.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 25th February 2007, 01:07
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Cool

Wheter or not it's an email client, it's serverbased. So you should have total control over the application/interface and how it shows to the client. Because you have control, there has to be a solution for this problem without the interaction of a user.

In vpostmaster, they use this as the domainname:
trim(implode('', file('/etc/'.(file.exists('/etc/mailname')?'mail':'host').'name')))

I can't make a thing of it, except that it somehow breaks the name into a logical email address. I didn't find a file /etc/mailname either, so I still don't have a clue???

I found a plugin though, through squirrelmail and I will have a look at it. It uses the url of the website and cuts the domainname and uses that in combination with the username for the e-mail address (or something like that). If you have a valid SSL certificate this doesn't work for you, because you have to have an SSL certificate for EVERY domain.

Another plugin excists where a new user is directed to his personal information, right after his first login.

Greets,
Remon Varkevisser

Last edited by rvarkevisser; 25th February 2007 at 01:10.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
Postfix Email Delivery Problem sedat1903 HOWTO-Related Questions 2 22nd December 2008 12:19
problem with incoming email sumwoman Installation/Configuration 7 27th January 2007 09:09
Weird problem when sending email from a PHP form. edge Installation/Configuration 5 5th September 2006 17:57
Problem with 'CC' & 'BCC' email not being delivered. snowfly HOWTO-Related Questions 10 20th July 2006 13:36


All times are GMT +2. The time now is 01:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.