#1  
Old 24th January 2007, 11:56
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
Default Software RAID1 + LVM on FC5

I was hoping someone could point me to a good tutorial or maybe throw out some tips on software RAID1 + LVM for FC5. I tried setting it up during install but it's not working right and I'm not sure what's wrong. Being a total linux noob I can't seem to figure out what to do next. Maybe these things can help you to point me in the right direction...

fdisk -l shows:
Code:
Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   fd  Linux raid autodetect
/dev/sda2              14       38913   312464250   fd  Linux raid autodetect

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   fd  Linux raid autodetect
/dev/sdb2              14       38913   312464250   fd  Linux raid autodetect

Disk /dev/md1: 319.9 GB, 319963267072 bytes
2 heads, 4 sectors/track, 78116032 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md1 doesn't contain a valid partition table

Disk /dev/md0: 106 MB, 106823680 bytes
2 heads, 4 sectors/track, 26080 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md0 doesn't contain a valid partition table
and cat /proc/mdstat shows:
Code:
Personalities : [raid1] 
md0 : active raid1 sdb1[1]
      104320 blocks [2/1] [_U]
      
md1 : active raid1 sdb2[1]
      312464128 blocks [2/1] [_U]
      
unused devices: <none>
which is all fine and dandy but I don't really understand what it all means. I'm trying to setup two disks to mirror each other so if one fails the other picks up the slack. Simple redundancy (not worried about speed) I appreciate any help.

Thanks!

~D
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2007, 18:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Your RAID array is broken (if it was ok it would show [UU] instead of [_U]).

Did you take a look at this tutorial? http://www.howtoforge.com/linux_lvm
That should help you getting started.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th February 2007, 12:52
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
Default

*SIGH* I think the problem is... because I'm so new to linux, stuff like this reads like stereo instructions. I understand partitioning and fdisk and format when your talking about win32 but not linux. After reading the above suggested tutorial, I'm even more confused. I know this makes me sound like a tard but... could you suggest something a touch more uh.... for dummies? I'd really appreciate it. I'd like to get my RAID fixed. thanks!
Reply With Quote
  #4  
Old 6th February 2007, 13:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by Daisy
could you suggest something a touch more uh.... for dummies? I'd really appreciate it. I'd like to get my RAID fixed. thanks!
This tutorial is already for beginners. Did you download the virtual machine that comes with the tutorial?

You might also want to take a look at this tutorial: http://www.howtoforge.com/replacing_..._a_raid1_array (but it's for RAID1).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Beginner's Guide To LVM borgward HOWTO-Related Questions 8 24th January 2007 15:39
Pre-check of software installed nemesis Developers' Forum 3 25th September 2006 01:23
hardware RAID1 and new HDD's edge Installation/Configuration 1 4th June 2006 15:28
xen + raid1 aqua HOWTO-Related Questions 10 2nd April 2006 23:08
Xen: Smp & Lvm zokahn HOWTO-Related Questions 5 27th January 2006 10:28


All times are GMT +2. The time now is 18:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.