View Single Post
  #7  
Old 17th December 2007, 20:07
kadi kadi is offline
Senior Member
 
Join Date: Sep 2007
Posts: 102
Thanks: 49
Thanked 2 Times in 2 Posts
Smile Thanks mr/falco again

hello mr/falco again
I really apreciate you help very much.
I added records like you said in the previous post and i think it not the dns
the problem may be either it is comming from the router or one of my files
is not right because i add the index page to:
/var/www/web1/web/kandkmarket.com
and still on my server it says : (server not found) also from other computers
(page cannot be displayed), I put the sites available for kandkmarket and link it
to sites enabled also and i will give you here what the (vhosts_ispconfig) looks
like , & sites enabled (www.kandkmarket also looks like:

vhosts_ispconfig :
-------------------------------
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.0.100:80
<VirtualHost 192.168.0.100:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.kandkmarket.com:80
######################################
#
#
<VirtualHost 192.168.0.100:80>
SuexecUserGroup nobody web1
ServerName www.kandkmarket.com:80
ServerAdmin webmaster@kandkmarket.com
DocumentRoot /var/www/web1/web
ServerAlias www.kandkmarket.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /var/www/web1/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /var/www/web1/phptmp/
php_admin_value session.save_path /var/www/web1/phptmp/
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#
-----------------------------------------------------------------------------------------
here is sites enabled (www.kandkmarket.com
---------------------------------------------------------------
#
# kandkmarket.com (/etc/apache2/sites-available/www.kandkmarket.com)
#
<VirtualHost *>
ServerAdmin webmaster@kandkmarket.com
ServerName www.kandkmarket.com
ServerAlias kandkmarket.com
# Indexes + Directory Root.
DirectoryIndex index.html
DocumentRoot /var/www/web1/web

# CGI Directory
ScriptAlias /cgi-bin /var/www/web1/cgi-bin
<Location /cgi-bin>
Options +ExecCGI
</Location>


# Logfiles
ErrorLog /var/www//web1/log/error.log
CustomLog /var/www/web1/log/access.log combined
</VirtualHost>
-----------------------------------------------------------------------------------
Here is Bind (named.conf)
-------------------------------------
options {
pid-file "/var/run/bind/run/named.pid";
directory "/etc/bind";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "db.root";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "db.local";
};

zone "0.168.192.in-addr.arpa" {
type master;
file "pri.0.168.192.in-addr.arpa";
};


zone "kandkmarket.com" {
type master;
file "pri.kandkmarket.com";
};


zone "kandkmarket.com" {
type slave;
file "sec.kandkmarket.com";
masters { 192.168.0.100; };
};


//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////

-------------------------------------------------------------------------------------------
Here is the /etc/hostname file:
----------------------------------
kserver.kandkmarket.com
==========================
Also the /etc/hosts file
---------------------------------
# 'hosts' file configuration.

127.0.0.1 localhost.localdomain localhost
192.168.0.100 kserver.kandkmarket.com kserver


# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
===============================================
By the way i thought about changing the port on the router may be that is what it is,
and when i try to add (service, rules) i got (Inbound) & (outbound) i didn't know which one
to choose + There is (start port) & (end port) inside both inbound & outbound
If i try this address: http://192.168.0.100/www.kandkmarket.com i got:
The requested URL /www.kandkmarket.com/ was not found on this server.
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch7 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at 192.168.0.100 Port 80
and try this one :http://127.0.0.1/www.kandkmarket.com i got the index page.
I hope i am not bothering you too much, i know your time is valuable.
I almost gave up on this server but i hate to go to others OS, i know i filled
up those posts with my files and sorry about that.
for now i can see everything under (services) in ispconfig (online)
so at least we correct this part thanks to you.
Thanks alot again.

Last edited by kadi; 18th December 2007 at 04:27.
Reply With Quote