View Single Post
  #8  
Old 14th December 2007, 18:11
llamy llamy is offline
Member
 
Join Date: Jun 2007
Posts: 80
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Ok I know where the problem is now but cannot solved it.

First thanks Till, the command locate postmap returns /usr/sbin/postmap then i was able to run it, but it did not solved the problem.

while i try to send a mail to info@mydomain.com with webmail i received : Mail Delivery System Undelivered Mail Returned t..., and the content of it is the following :

The mail system



<postmaster@host.myispconfig_domain.com> (expanded from <info@mydomain.com>):

Host or domain name not found. Name service error for

name=myispconfig_domain.com type=A: Host not found



--1DBF7ED0002.1197645187/monster.tagatbolivia.com

Content-Description: Delivery report

Content-Type: message/delivery-status



Reporting-MTA: dns; monster.tagatbolivia.com

X-Postfix-Queue-ID: 1DBF7ED0002

X-Postfix-Sender: rfc822; sample_user@mydomain.com

Arrival-Date: Fri, 14 Dec 2007 11:13:07 -0400 (BOT)



Final-Recipient: rfc822; postmaster@host.myispconfig_domain.com

Original-Recipient: rfc822;info@mydomain.com

Action: failed

Status: 5.4.4

Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error

for name=host.myispconfig_domain.com type=A: Host not found



So if i understand the mail system cannot resolved the ispconfig domain name(myispconfig_domain.com) which is different from the one i register my website(mydomain.com), this is normal since i did not register on godaddy the ISPConfig domain name, hoping for future customers to reach it by his IP address.

Now as it said in the postfix main.cf file :

# INTERNET HOST AND DOMAIN NAMES
#
# The myhostname parameter specifies the internet hostname of this
# mail system. The default is to use the fully-qualified domain name
# from gethostname(). $myhostname is used as a default value for many
# other configuration parameters.
#
#myhostname = host.domain.tld
#myhostname = virtual.domain.tld

# The mydomain parameter specifies the local internet domain name.
# The default is to use $myhostname minus the first component.
# $mydomain is used as a default value for many other configuration
# parameters.
#
mydomain = mydomain.com
#mydomain = domain.tld


So as you can see i have change the mydomain value to the corresponding domain vale of my website, but it does not change nothing because postfix always use the result of gethostname() to fix the hostname and the domain values.

So now the question is how to force postfix to use my website domain instead of the ispconfig server domain is there any postfix command to set that, because for security reasons i prefer to have a different domain name of ISPconfig server and my website although they both reside on the same FC6 Box.

Thanks.
Reply With Quote