View Single Post
  #1  
Old 2nd December 2007, 13:52
mbria mbria is offline
Junior Member
 
Join Date: Jul 2007
Posts: 17
Thanks: 12
Thanked 2 Times in 2 Posts
Default Ignored phpvalues at .htaccess, ISPconfig or PHP

Hi all,

One of my new sites requires some special tunning of php_values, but never mind where I set them, it didn't work.

My server is:
- ubuntu 7.04 (following perfect setup)
- suPHP (following suPHP howto)
- ISPconfig 2.2.16

My goal is setting those variables as follows, just in one site:

* post_max_size=100M
* upload_max_filesize=100M
* max_execution_time=1000
* max_input_time=1000

I tried at ISPconfig setting "Apache Directives" to:

PHP Code:
...
<
Directory /var/www/web3/web>  
Options +Includes +FollowSymlinks -Indexes  
AllowOverride All  
Order allow
,deny  
Allow from all
php_value post_max_size 500
<Files "^\.ht">  
Deny from all  
</Files>  
</
Directory>
... 
And also at it's own .htaccess with multiple variants:

PHP Code:
#php_value post_max_size "100M"
#php_value upload_max_filesize "100M"
#php_value max_execution_time "1000"
#php_value max_input_time "1000"
<IfModule mod_php5.c>
php_flag post_max_size 50
php_value post_max_size 50
</IfModule
Finally I tried directly at the CMS (it's a Drupal) config file... where other variables are set:

PHP Code:
ini_set('post_max_size',            '100M');
ini_set('upload_max_filesize',     '100M');
ini_set('max_execution_time',    '1000');
ini_set('max_input_time',           '1000'); 
As said, non of those solutions work.

Any clue about how to fix this?

Thanks a lot for your self,

m.
Reply With Quote
Sponsored Links