View Single Post
  #1  
Old 4th November 2007, 05:00
Kai Kai is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Question Installing Xen On An Ubuntu Feisty Fawn Server From The Ubuntu Repositories: On 7.10

Hi all,

I am trying to make myself a home server sonsisting of multiple Xen VMs for different purposes.
But before I get to the point I can have some fun configureing the VMs I need to create them first, and thats where I am stuck.

I installed Ubuntu 7.10 Desktop on my server (since I didnt get the GUI working on the server edition) and is now fiddling with the xen-tools.

And I thought this howto wouldnt be far off my set up, but its not working

I followd the instruction (with some modifications) and the xen-create-image command halts on "Installation method: debootstrap", I can hear some disk activity for some seconds and I see some blinking on the NIC but after maby a minute the keyboard stops working and the mouse poniter gets really sluggish and nothing else works so I have to hard reboot the system.

Here is my create command:
xen-create-image --hostname=foo --size=4Gb --swap=256Mb --ide \
--dhcp --force \
--dir=/vserver --memory=256Mb --arch=i386 --kernel=/boot/vmlinuz-2.6.22-14-xen \
--initrd=/boot/initrd.img-2.6.22-14-xen --debootstrap --dist=gutsy \
--mirror=http://no.archive.ubuntu.com/ubuntu/ --passwd

I might have made one mistake though, I tried to do it myself before I looked up the howto and installed the ubuntu-xen-desktop package instead of the server one in the guide. But from what I can tell its the same thing with added GUI stuff.

Another thing I am not sure of is that the server is directly connected to my cable modem with DHCP since I dont have a router (wich will be the first task I will give this box). And since the host system is also using DHCP with only one address available, I am not sure how Xen responds to this. I tried to set the main interface to 0.0.0.0 before I ran the create command but there was no progress.


Any clues?
Reply With Quote
Sponsored Links