View Single Post
  #1  
Old 19th October 2007, 23:53
cruz cruz is offline
Senior Member
 
Join Date: Apr 2007
Posts: 365
Thanks: 51
Thanked 2 Times in 2 Posts
Default apache not working

I posted this someware else and I do not know if it was suppose to post it in this area. Anyhow. I changed the file /home/admispconfig/ispconfig/lib/config.inc.php. because I was getting errors on the php log
HTML Code:
 an unknown filter was not added: PHP
I added the string that was told in this posting.
HTML Code:
This has already been fixed many releases ago. You will just have to change the line from:

$go_info["server"]["apache2_php"] = 'both'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


to:

$go_info["server"]["apache2_php"] = 'addtype'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


in the file /home/admispconfig/ispconfig/lib/config.inc.php
I do not know if this is what caused the web server not to work, but after I changed this it stoped working. I had copied the file before I changed it, so I recopied it back to the server. But it did not fix it. I looked into apache file and can see red marks on two files. php4.conf and php4.load. this is the error message I get when booting the server.
HTML Code:
syntac error on line 185 of/etc/apache2/apache2.config could not open configuration file /etc/apache2/mods-enable/php4.load no such file or directory
Now I have php5 on here. Why is it trying to load php4? Please help, my server is down. But I can login to the servers ispconfig councal, but my website is down. Thanks

P.S. new info. I went to the files that had the red marks and tried to open them with winSCP and it is telling me. can't open remote file.then it has the path to the files (php4.config php4.load) I hope this helps. thanks

Last edited by cruz; 20th October 2007 at 00:07.
Reply With Quote
Sponsored Links