View Single Post
  #6  
Old 27th September 2007, 22:03
thirtythree thirtythree is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

ATI Radeon Mobility x1300 is now running 3D with the fglrx driver. This is how I did it:

I want to preface this with the following: I am fairly new to linux, and have spent the last week or so trying desperately to get this up and running. I searched all over the internet and found a million threads like this one. I tried everything I could find, nothing worked. In the end, what worked was to read every ounce of documentation provided with the driver, my video card, and my operating system, including the error logs. Half the time, I didn't know what I was reading. So I took notes, documented my progress, deduced the best possible course of action.

On the night that I got this working, I started fresh. Spent 6 hours reading everything from the beginning, and kept a log. At the end of the 6 hours, I enacted a game plan that I had just came up with. I got my card working ON THE FIRST TRY. So the lesson is, understand what you are doing, and read till your eyes bleed. Nothing is easy if you look for an easy fix. Best to hack at it and understand why things are how they are. Without further ado...

My setup:
open SuSE linux 10.2
kernel 2.6.18.2-34
KDE 3.5.5
ATI Radeon Mobility x1300
32 bit
Dell Inspiron E1505 laptop, Intel Core Duo

I don't know enough about linux to know if the following steps will work on anybody elses card or kernel. Like I said above, use your reading skills to read the documentation. It should tell you exactly what you need to know.

Note: You must be using kernel 2.4 or higher

Step 1. Download the driver from the ATI site. I downloaded 8.40.4-x86.86_64.run, this was the most current driver as of this week.

Step 2. While at the ATI website, grab the provided documentation for your driver. You will need this for further steps.

Step 3. You must have shared memory enabled to use the 3D features of this driver. To do this, go add this line to your /etc/fstab :
tmpfs /dev/shm tmpfs defaults 0 0
(note - unless you reboot, you will need to mount this, use mount /dev/shm)

Step 4. Use your respective software installation tool (Yast) to ensure you have all the proper dependencies for the driver. These include the following:

# glibc version 2.2 or 2.3
# XOrg 6.7, 6.8, 6.9, 7.0, 7.1, or 7.2; XFree86 version 4.3
# XFree86-Mesa-libGL
# libstdc++
# libgcc
# XFree86-libs
# fontconfig
# freetype
# zlib
# gcc
# kernel-source (this must match your kernel-default version)
# qt3
# compat
# compat-libstdc++
# libstdc++-devel
# xorg-x11-libs
# xorg-x11-devel
# Mesa
# Mesa-devel
# fontconfig-devel
# expat
# freetype2
# freetype2-devel
# zlib
# zlib-devel
# libdrm VERSION 2.3

Step 5. As per the ATI documentation...
Quote:
If a Linux 2.6.11 or newer kernel was built with CONFIG_AGP enabled, the kernel AGP frontend is required to load the fglrx kernel module. To identify whether your kernel was built with CONFIG_AGP enabled, look for CONFIG_AGP=y in the kernel config file, or if the 'agpgart' module loaded.
So do an lsmod | grep agpgart and make sure it is in there.
If you have been trying to install without this, you will know if from a bunch of errors about a kernel issue leading to a fail to install message.

Step 6. If you have been trying to get this to work before, and have "installed" the driver before, you must clear your machine of all previous versions of the driver before you proceede.

Go to runlevel 3 ->
# su
# init 3
Then remove the previous driver
# cd /usr/src/linux
# make mrproper
# make cloneconfig
# make modules_prepare
# make clean
# rpm -e $(rpm -qa | grep fglrx)

Step 7. Generate the driver package. Navigate to where you downloaded the driver and do the following ->
# sh ati-driver-installer-8.40.4-x86.x86_64.run --listpkg

Step 8. You will get a list of distributions from which you can build the driver, which looks like this...

Quote:
SuSE/NLD9-IA32
SuSE/SLES9-IA32
SuSE/SUSE91-IA32
SuSE/NLD9-AMD64
SuSE/SLES9-AMD64
SuSE/SUSE91-AMD64
SuSE/SUSE100-IA32
SuSE/SUSE92-IA32
SuSE/SUSE93-IA32
SuSE/SUSE100-AMD64
SuSE/SUSE92-AMD64
SuSE/SUSE93-AMD64
SuSE/SLED10-IA32
SuSE/SLES10-IA32
SuSE/SUSE101-IA32
SuSE/SLED10-AMD64
SuSE/SLES10-AMD64
SuSE/SUSE101-AMD64
SuSE/SUSE102-IA32
SuSE/SUSE102-AMD64
Build the distribution of your choice
# sh ati*.run --buildpkg SuSE/SUSE102-IA32

Step 9. Now you have a driver in /usr/src/packages/RPMS/i386
So go to that directory
# cd /usr/src/packages/RPMS/i386
and
# rpm -Uvh fgl*.rpm

See next post for the rest...
Reply With Quote