View Single Post
  #1  
Old 26th September 2007, 18:20
erebus erebus is offline
Member
 
Join Date: Sep 2007
Posts: 63
Thanks: 10
Thanked 9 Times in 9 Posts
Exclamation SERIOUS ISPConfig + MySQL bug?

Hello all,

I was playing around today created demo resellers and users to see how ISPConfig behaves. Here is the scenario:

1) As admin I have created a demo reseller with (among other) a privilege to create 10 MySQL DBs.

2) I login as this demo reseller and created a demo website with a limit of 1 MySQL DB. For this website, I create a MySQL DB and a MySQL user. When I tried to create more DBs, ISPConfig says that I have reached the limit (which is normal).

3) I then login with this MySQL user credentials in phpmyadmin. The username is web11_u1 and the database is web11_db1 (which is normal).

Now comes the problem.

When I logged in for the first time in phpmyadmin, I saw the created database 'web11_db1' and phpmyadmin proposed me to create if I want another db with the auto provided name 'web11?db1' (don't know why). So I tried and guess what happened. I was able to create it!

So I tried to create more databases (always having logged in as web11_u1) and I reached to the following conclusion: I cannot create databases with any name I want (i.e. abcdef is not accepted) HOWEVER I CAN CREATE DBs with names similar to my originally created database name. So far I have already created these dbs:

web11*u1
web11&u1
web11-u1
web11?u1

...which I suppose is a serious issue.

So please, have a look at it and give us a quick workaround.

Thank you,

P.S. I have thought to disable the database creation from phpmyadmin's config, however I don't think that this would solve the problem as it seems there is a problem with the credentials and not with the frontend itself.
Reply With Quote
Sponsored Links