View Single Post
  #1  
Old 16th September 2007, 03:17
danielvm danielvm is offline
Junior Member
 
Join Date: Sep 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Send problems (postfix)

Hi everyone, i have installed a mail server using postfix, courier-imap, ldap, amavisd-new, spamassassin, clamav, everithing was ok, but now i'm trying to secure the client conection using sasl and tls but i have a problem and i hope find good answer or clues here.

* I can send email using ssl on port 465 in outlook express and thunderbird, but the mails doesn't get to my mailbox, if i run mailq the mail is in the queue i don't know why. Furthermore i can send the email with or without requiring user autenthicated and with or without use ssl and i would like to enforce the use of bot SMT-AUTH and TLS.

Here is postconf -n

Quote:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
bounce_size_limit = 50000
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
default_destination_concurrency_limit = 15
disable_vrfy_command = yes
header_checks = pcre:/etc/postfix/header_checks
home_mailbox = Maildir/
inet_interfaces = all
local_destination_concurrency_limit = 3
local_header_rewrite_clients = permit_mynetworks
local_recipient_maps = unixasswd.byname, proxy:ldap:/etc/postfix/ldap/local_recipients.cf, $alias_maps, $virtual_alias_maps
mailbox_size_limit = 100000000
maximal_backoff_time = 8000s
maximal_queue_lifetime = 5d
message_size_limit = 10485760
mime_header_checks = regexp:/etc/postfix/mime_header_checks
minimal_backoff_time = 1000s
mydestination = $myhostname, localhost.$mydomain, $mydomain
mydomain = dominio.com
myhostname = server.dominio.com
mynetworks = 127.0.0.0/8
myorigin = $mydomain
receive_override_options = no_address_mappings
recipient_delimiter = +
relayhost =
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_tls_CAfile = /usr/local/CA/cacert.pem
smtp_tls_cert_file = /usr/local/CA/smtpcert.pem
smtp_tls_key_file = /usr/local/CA/smtpkey.pem
smtp_tls_loglevel = 3
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP
smtpd_client_connection_count_limit = 35
smtpd_delay_reject = yes
smtpd_error_sleep_time = 0
smtpd_helo_required = yes
smtpd_helo_restrictions = reject_invalid_hostname, permit
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unknown_sender_domain, reject_non_fqdn_recipient, reject_invalid_hostname, reject_multi_recipient_bounce, reject_unknown_recipient_domain, check_sender_access hash:/etc/postfix/access, permit_mynetworks, check_helo_access pcre:/etc/postfix/helo_checks, reject_unauth_destination, reject_unauth_pipelining, reject_unverified_sender, reject_rbl_client cbl.abuseat.org, reject_rhsbl_sender dsn.rfc-ignorant.org, reject_rbl_client sbl-xbl.spamhaus.org, reject_rbl_client blackholes.easynet.nl, reject_rbl_client dnsbl.njabl.org reject_rbl_client proxies.blackholes.wirehub.net, reject_rbl_client sbl.spamhaus.org, reject_rbl_client list.dsbl.org, reject_rhsbl_client blackhole.securitysage.com, reject_rhsbl_sender blackhole.securitysage.com, reject_rbl_client dynablock.wirehub.net, permit
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_tls_security_options = noanonymous
smtpd_sender_login_maps = ldap:/etc/postfix/ldap/sender_login_maps.cf
smtpd_sender_restrictions = reject_non_fqdn_sender, reject_unknown_sender_domain, check_sender_access hash:/etc/postfix/access, permit
smtpd_tls_CAfile = /usr/local/CA/cacert.pem
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /usr/local/CA/smtpcert.pem
smtpd_tls_key_file = /usr/local/CA/smtpkey.pem
smtpd_tls_loglevel = 3
smtpd_tls_received_header = yes
smtpd_use_tls = yes
strict_rfc821_envelopes = yes
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transports
unknown_local_recipient_reject_code = 450
virtual_alias_maps = hash:/etc/aliases, proxy:ldap:/etc/postfix/ldap/local_recipients.cf, hash:/etc/postfix/virtual.cf
Here is my master.cf

Quote:
#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - - - - smtpd -v
#submission inet n - - - - smtpd
# -o smtpd_enforce_tls=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
#smtps inet n - - - - smtpd
#smtps inet n - n - - smtpd
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
#Anterior tls
#tlsmgr unix - - - 1000? 1 tlsmgr
#tlsmgr unix - - n 300 1 tlsmgr
tlsmgr unix - - - 300 1 tlsmgr
#rewrite unix - - n - - trivial-rewrite
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} -w 80
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}

#smtps inet n - n - - smtpd
smtps inet n - - - - smtpd
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
#587 inet n - n - - smtpd
587 inet n - - - - smtpd
-o smtpd_enforce_tls=yes
-o smtpd_sasl_auth_enable=yes

amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,rej ect
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_chec ks,no_header_body_checks
-o smtpd_bind_address=127.0.0.1
Please i need help

the system is debian etch

Thanks

PD: sorry about my english but i speak spanish
Reply With Quote
Sponsored Links