View Single Post
  #1  
Old 12th September 2007, 05:28
claudioimai claudioimai is offline
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 4
Thanked 0 Times in 0 Posts
Question Discrepance between ISPConfig panel and database

Hello.

I had a problem a few days ago regarding the SSL for some sites I have.

I made some changes in the ISPConfig panel, trying to set the new IPs for each of the sites, moving ssl certs into ISPConfig - which is not possible, and such things.

I messed something in the process and now I have some problems.
  • I have in a site: domain www(hostname) and varejo29.net as domain.
  • in the co-domains tab, I have www(hostname) and varejo29.net as domain
  • on another entry: hostname is empty; varejo29.net is the domain
For this one, the co-domain entry with www.varejo29.net is wrong?

Second: the IP for this domain is correct: 74.47.195.34 in the panel, but the bind configuration files still shows the main server's IP: 88.198.133.14

I decided to look into the database for ispconfig, and it shows me in the table dns_isp_dns the entries for varejo29.net all pointing to 88.198.133.14
I took the chances (after doing a backup, for sure) and changed these entries manually to the correct IP, stopped and restarted bind9.
Luckily, the bind entries were corrected now.

Things seems to be correct, but I know only the surface of these configs, so can anyone point me some reason for this faulty behaviour, and if there is possibly anything else wrong?

(I wonder why ISPConfig shows one IP and the database showed another -in the mentioned table, at least?)
Reply With Quote
Sponsored Links