View Single Post
  #6  
Old 5th September 2007, 12:41
shellNewbie shellNewbie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default Editing hosts file to access ISPconfig control panel locally

Thank you again chuckl - that last post is very informative.

I edited the hosts file on my windows pc and added this entry

192.168.abc.abc www.(mydomainname).com

(where abc replaces the static IP I gave my ubuntu server)

- I type http://www.(mydomainname).com into my browser - I get to the parent directory of my server machine which contains 3 folders:

Index of /
Name Last modified Size Description

--------------------------------------------------------------------------------

apache2-default/ 21-Nov-2004 06:46 -
sharedip/ 04-Sep-2007 16:29 -
webalizer/ 04-Sep-2007 16:11 -

--------------------------------------------------------------------------------


Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at .www.(mydomainname).com Port 80


-- Inside the "sharedip" folder is an ISPConfig page which says:

This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

For questions or problems please contact the server administrator.


--------------------------------------------------------------------------------

powered by ISPConfig

--I type the static address of my server box into my browser (192.168.abc.abc) and I come to the same parent directory.

Now - If I type 192.168.abc.abc:81 into my browser I get this:

Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.


Hint: https://192.168.abc.abc:81/


--------------------------------------------------------------------------------

Apache/1.3.37 Server at 192.168.abc.abc Port 81

-- So I click on the hint (which is a link) and go nowhere. (maybe because I left the hostname blank at the end of the ISPConfig when it kept saying that the URL is unreachable)

I have 3 questions here please - If my domain name is www.(mydomainname).com and the static IP of my ubuntu server machine is 192.168.abc.abc:

Question 1: Can you please tell me exactly what to write when the ISPConfig install asks -
Please enter the host name (e.g. www):
Question 2: Can you please tell me exactly what to write when the ISPConfig install asks -
Please enter the domain (e.g. xyz.de):
Question 3: If I had edited the hosts file on my windows PC before installing ISPConfig would that have prevented this error:


Please enter the host name (e.g. www):www.(mydomainname).com
Please enter the domain (e.g. xyz.de):192.168.abc.abc
The URL is not reachable![/COLOR]

or does it look like I have done something else wrong?

All I want is to use ISPConfig to set up and maintain my own website from home.

Thanks for your patience.
Reply With Quote