View Single Post
  #7  
Old 7th December 2005, 17:56
SeaWolf SeaWolf is offline
Member
 
Join Date: Sep 2005
Location: Montréal, Canada
Posts: 39
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to SeaWolf Send a message via Skype™ to SeaWolf
Cool

Ok, I've just installed from scratch Suse 10 with the Perfect Setup and install ISPConfig. I will let you know all error msg appear when I do some mods.

Fresh install, Suse Linux 10 on 64bit P4 computer with ISPConfig 2.1.1.

Here we go:

Quote:
Without modifications:
configure: error: Cannot find libmysqlclient under /usr.
Note that the MySQL client library is not bundled anymore.
ERROR: Could not configure PHP
Quote:
Modifications 1 (
mkdir /usr/local/lib/mysql
cd /usr/local/lib/mysql
ln -s /usr/include/mysql include
ln -s /usr/lib64/mysql lib
and change that line:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
)

configure: error: Cannot find OpenSSL's <evp.h>
ERROR: Could not configure PHP
Quote:
Modifications 2 (
All modifications 1 +
install openssl-devel
)

configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP
Quote:
Modifications 3 (
All modifications 2 +
change that line:
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=/usr/include/openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
)

configure: error: Cannot find OpenSSL's <evp.h>
ERROR: Could not configure PHP
I've deleted all files before each tries and all error messages apears in "Configuring extensions" section.

If you have other ideas lemme know!

Hope it will help!

Thanks.

Last edited by SeaWolf; 7th December 2005 at 18:02.
Reply With Quote