View Single Post
  #15  
Old 29th August 2007, 19:12
CaptainBalou CaptainBalou is offline
Junior Member
 
Join Date: Aug 2007
Posts: 29
Thanks: 8
Thanked 1 Time in 1 Post
Default

Yes, it's strange. So I talked to the support for my vserver a few minutes before.

- They confirmed that it is a 64-bit host system.
- They also confirmed that the "uname -m" looks strange.
- They told me to use the *x86_64.rpm files.

But for sure they had no solution for the compilation problem...

I tried another trick last night:
I found many others via google they also have problems while compiling openssl. Nearly or completely the same errors. I read about a "workaround" which is also mentioned in the INSTALL-readme in the openssl package: compile with "no-asm". The compilation worked fine without any errors. I was lucky! But it lasts just a few seconds. The generation of the certificates which is done via the mkcert.sh in your setup2 or somewhere doesn't work properly then. It tries to generate a certificate (many "." are printed to screen) but the generator never ends. I canceled it after about two minutes of "whatching dots". I don't know if it is another problem or just the result of the "quick and dirty hack" with the openssl package.

I don't know what to test else...
Marco
Reply With Quote