View Single Post
  #1  
Old 24th August 2007, 23:44
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default Send email to domain with MX record on other server?

I've been trying for some days now, but till now with no luck.

In ISPconfig I've got a domain www.somename.com (lets call this server server_1).
The website and DNS is running on this ISPconfig server (server_1), but the email for that domain is on an other server (lets call it server_2)

Within ISPconfig (server 1) I've created the domain www.somename.com.
For the domain www.somename.com I've enabled Create DNS.
I've also created an user & email as I needed it to FTP to the site.
I also set the Mailserver (under the tab options) to External Mailserver.

In the DNS for domainname.com I've setthe MX record to an A record that points to the server that is used for mail.

Problem.
When I email with a user account that does run on the ISPconfig (server_1) to somename.com, the mail will not go to server_2 (it get an error saying "Your message did not reach some or all of the intended recipients. Recipient address rejected: User unknown in local recipient table"
(note that this is only when I use an email account that is on server_1)

Looking at /etc/postfix/local-host-names it does still show somename.com
Should the option "External Mailserver" not remove this from the local-host-names file?

When I use an account that is NOT running op server_1, mail (gmail, hotmail etc... ) all is working fine for somename.com

Anyone here who might know what is going on?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Sponsored Links