View Single Post
  #1  
Old 22nd August 2007, 23:26
giganet giganet is offline
Senior Member
 
Join Date: Aug 2007
Location: California
Posts: 243
Thanks: 116
Thanked 1 Time in 1 Post
Send a message via AIM to giganet
Question PHPMyAdmin Link Only Offers Download or View With

Hello Group

Ubuntu 6.06
Server version: Apache/1.3.34 (Ubuntu)
Server built: Jul 26 2006 09:10:06
PHP 5.1.2 (cli) (built: Jul 17 2007 17:32:48)

I have have been following the tutrial http://flurdy.com/docs/postfix and am not completed with the setup process however I am at the phase of getting ready to test if the email server is functioning to this point.

Anyhow, I am told I should be able to create mysql tables by 'command line' OR by using 'phpmyadmin'.
When I am at the server index which displays links to 'apache2-default' which takes me to the apache test page and also the 'phpmyadmin' link which when clicked on only offers to doanload the file or view it by selecting a local app.
I have created a 'test.php' file in '/var/www/test.php' but when I click on it I get the same result- Save OR View??

What am I doing wrong, why won't 'phpmyadmin' work as it should?

I ran 'sudo dpkg -l' and the list shows that both 'apache' and 'apache2' are installed in addition to that the list also shows 'php4' & 'php5' as being installed too!
According to the flurdy tutorial I am following the only pacakges to be used are 'apache2' and 'php4'...
It seems by this tutorial that 'SquirrelMail' is only compatible with 'php4' and not 'php5' - I guess??

If I restart apache all is fine.
But if I attempt to do the same with apache2
Code:
sudo /etc/init.d/apache2 restart
 * Forcing reload of apache 2.0 web server...                                                                                apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
Another note would be that when I access the server by IP using a browser the index does display links as I defined above, but it bothers me with it's referral to apache2- when I run 'apache -v' it returns 1.3.34 not 2.

Should I 'apt-get remove apache' && 'apt-get remove php4' or what- I'm not sure?

Oh Yeah, I fogot this-- I edited '/etc/mysql/config.inc.php' ALSO
host = localhost
auth_type = config
user = root
password = xxxxx

Can someone provide a n00b! some guidance please?

Thank you

Regards

Last edited by giganet; 22nd August 2007 at 23:32.
Reply With Quote
Sponsored Links