View Single Post
  #2  
Old 10th August 2005, 07:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,476
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Quote:
Originally Posted by latcarf
I reinstalled FC4 and then proceeded to install ISPConfig but it experienced problems at the end
Code:
Warning: main(config.inc.php): failed to open stream: No such file or directory in /home/install_ispconfig/install.php on line 624

Warning: main(): Failed opening 'config.inc.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/install_ispconfig/install.php on line 624

Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /home/install_ispconfig/install.php on line 634
Could not connect to db
Restarting some services...
./setup2: line 831: [: ==: unary operator expected
./setup2: line 849: /etc/rc.d/init.d/ispconfig_server: No such file or directory
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Despite the last line it won't go to the login page. It worked on the previous install but I think I may have installed it from the wrong directory this time.

What directory should ISPConfig be installed from/on? ?
You can install it from any directory, as long as you first enter the install_ispconfig directory and then start the setup like this
Code:
./setup
from inside the directory.

I assume you got this error because you tried to install ISPConfig before and that install was interrupted and you dont have extracted the installer tar.gz again.

Quote:
Originally Posted by latcarf
Will #apt-get remove ispconfig# remove the current intall?
To uninstall ISPConfig, run the following script:

Code:
/root/ispconfig/uninstall
If the uninstall script is not there, you can delete the following directorys manually:

Code:
rm -rf /root/ispconfig
rm -rf /home/admispconfig
Reply With Quote