View Single Post
  #31  
Old 7th August 2007, 15:24
irDante irDante is offline
Junior Member
 
Join Date: Jul 2006
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

hmm..getting the same problem here.

I did an apt-get install webmin, which upgraded a few files....at the end of the webmin install it told me that there was an error with amavis...

apt-get install amavis
Reading Package Lists... Done
Building Dependency Tree... Done
Note, selecting amavisd-new instead of amavis
amavisd-new is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 99 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up amavisd-new (2.4.2-6.1) ...
Creating/updating amavis user account...
Starting amavisd: Found incompatible config file flag!
Due to safety concerns, amavisd-new will not be started.
Refer to /usr/share/doc/amavisd-new/README.Debian for instructions.
invoke-rc.d: initscript amavis, action "start" failed.
dpkg: error processing amavisd-new (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
amavisd-new
E: Sub-process /usr/bin/dpkg returned an error code (1)


mail log.
Aug 7 13:48:20 localhost postfix/smtp[31910]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Aug 7 13:48:20 localhost postfix/smtp[31911]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Aug 7 13:48:20 localhost postfix/smtp[31910]: 77D954C01E: to=<adamh@kzn.da.org.za>, relay=none, delay=2605, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Aug 7 13:48:20 localhost postfix/smtp[31910]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Aug 7 13:48:20 localhost postfix/smtp[31911]: 8D14E4C01B: to=<sec@kzn.da.org.za>, relay=none, delay=3213, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Aug 7 13:48:20 localhost postfix/smtp[31910]: 832264C01C: to=<suerog@mweb.co.za>, relay=none, delay=3179, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)

the strange thing here is...i looked in the /etc/amavis for the amavis.conf file...there was nothing. i had a backup which i copied back...but still not working.

/etc/init.d/amavis restart
Stopping amavisd: (not running).
Starting amavisd: Found incompatible config file flag!
Due to safety concerns, amavisd-new will not be started.
Refer to /usr/share/doc/amavisd-new/README.Debian for instructions.

i have gone though all the above advice....still nothing?

Reply With Quote
Sponsored Links