View Single Post
  #7  
Old 3rd December 2005, 16:39
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by nenad
Apache won't start due to following error:

Quote:
Starting httpd: Syntax error on line 10 of /etc/httpd/conf.d/perl.conf:
Cannot load /etc/httpd/modules/mod_perl.so into server: /etc/httpd/modules/mod_perl.so: undefined symbol: Perl_Ippid_ptr
Everything worked fine until I installed RRDTool.
Actually even then everyhting worked OK, untill I re-created server certificate with ISPConfig.

BTW I have a problem with apt-get too:




HELP!!!

OK. I found solution.

I done this:
-------------------------------------------------------------------
rpm -Uvh http://ftp.freshrpms.net/pub/freshrp....fr.noarch.rpm
yum update
-------------------------------------------------------------------
Then new Perl 5.8 ...etc. was installed altogether with depecies.
Then I uncommented again the line that was troublemaker in /etc/httpd/conf.d/perl.conf
and then I restarted httpd (service httpd restart)

Now everything works fine.

Note that new Perl-5.8... (whatever) was not avaiable in apt-get packages
It's a kind of bug in previous Perl package. Who want to find out more please use Google

Last edited by nenad; 3rd December 2005 at 16:44.
Reply With Quote