View Single Post
  #20  
Old 2nd August 2007, 15:37
dayjahone dayjahone is offline
Senior Member
 
Join Date: Jan 2007
Posts: 421
Thanks: 31
Thanked 0 Times in 0 Posts
Default

I did the following again:
Quote:
perl -MCPAN -e shell
install HTML::Parser
install DB_File
install Net:NS (when prompted to enable tests, choose "no")
install Digest::SHA1
then tried install ARCHIVE::TAR and got the following:
Quote:
cpan> install ARCHIVE::TAR
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Wed, 01 Aug 2007 10:50:03 GMT
Warning: Cannot install ARCHIVE::TAR, don't know what it is.
Try the command

i /ARCHIVE::TAR/

to find objects with matching identifiers.
install Archive::TAR worked, but when I tried to update spamAssassin after that, I get the following:
Quote:
mail:/home/admispconfig/ispconfig/tools/spamassassin/usr/bin # ./sa-updateCan't locate Archive/Tar.pm in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi /home/admispconfig/ispconfig/tools/spamassassin/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/5.8.5/i586-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl) at ./sa-update line 94.
BEGIN failed--compilation aborted at ./sa-update line 94.
Reply With Quote