View Single Post
  #6  
Old 29th November 2005, 14:15
sc0ut sc0ut is offline
Junior Member
 
Join Date: Oct 2005
Location: Bosnia and Herzegovina
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I wrote that ISPConfig added:
NameVirtualHost 207.210.77.xx:80
<VirtualHost 207.210.77.xx:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 207.210.77.xx:80
<VirtualHost 207.210.77.xx:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>

in Vhosts_ispconfig.conf, but somehow that page / directory was forbidden (got error 403 when tried to load it).
I added:

<Directory "/var/www/sharedip">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>

in /etc/apache2/default-server.conf, and now that page is accessible, and works fine.
I think ISPConfig should not alter that file, so the change will be permanent.

(just for the record, if someone else get the same error, I'm using SuSE 9.2 & apache 2.0.55, ISPConfig 2.1.1)
Reply With Quote