View Single Post
  #1  
Old 25th November 2005, 07:50
semmelbroesel semmelbroesel is offline
Junior Member
 
Join Date: Nov 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't get MX for external mail server to work

Hi,

my web site is hosted by a friend who knows enough about Linux to setup this server - I have hardly any clue about it. He just migrated the server to ISPConfig and will be gone for 24h, but in the meantime my email server is down, so I am hoping someone here can help me faster.

He used to have my MX record setup manually to go to my own PC at home using a dyndns.org domain. I have been playing with ISPConfig for an hour now and can't figure out how to have the MX record of my domain point to my external mail server.

I did find out that you need to have a co-domain setup and the mail server point to External and have MX record on. These are all set now, but something must still be wrong. I don't know if I can access mail logs etc. - I don't know how to since the server is in a different state and I don't know how to remote access the server (if he setup access for me - he just finished installing it again).

My setup is:
domain.com is the main domain.
I originally had it set to have www as hostname and domain.com as domain. I activated DNS and MX entry.
Then I created a co-domain without a hostname, checked MX record and DNS record for it.
In the DNS Manager, I entered mydomain.dyndns.org as mail server address.
Since it wouldn't work, I entered my mail server address for all domain combinations I could think of:
(empty), domain.com, www.domain.com, mail.domain.com, mail
Nothing works.
The email address is user@domain.com and is supposed to go to my external mail server, and it used to before ISPConfig was installed.

What can I do to get this to work?
If you need any information other than what I can get from the interface, please let me know how I can get it. SSH is installed, and I have used Putty before to login.

Thanks!
Reply With Quote
Sponsored Links