View Single Post
  #1  
Old 1st June 2007, 01:34
sambauser sambauser is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Trying to mount a Linux share on Windows

Hi,

I am trying to mount a Linux directory onto the Windows box.

The smb.conf file looks like this:

Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[profiles]"
Processing section "[users]"
Processing section "[groups]"
Processing section "[winshare]"
Loaded services file OK.
WARNING: passdb expand explicit = yes is deprecated
Server role: ROLE_STANDALONE
[global]
workgroup = OVE.LOCAL
map to guest = Bad User
valid users = root, linuxbak, amandabackup
force user = amandabackup

[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
create mask = 0600
directory mask = 0700
store dos attributes = Yes

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[winshare]
comment = Share for the Windows server ove-dc3bkup01
path = /media/winshare
write list = root, amandabackup, linuxbak
read only = No
create mask = 0600
directory mask = 0700
inherit acls = Yes

Also, can't seem to see the share below
AmandaBackup:/media # smbclient -L 10.80.101.15 -U linuxbak
Password:
Domain=[OVE] OS=[Windows Server 2003 R2 3790 Service Pack 1] Server=[Windows Server 2003 R2 5.2]

Sharename Type Comment
--------- ---- -------
C$ Disk Default share
S$ Disk Default share
F$ Disk Default share
IPC$ IPC Remote IPC
G$ Disk Default share
LinuxBak Disk
ADMIN$ Disk Remote Admin
SQL Bak Disk
E$ Disk Default share
session request to 10.80.101.15 failed (Called name not present)
session request to 10 failed (Called name not present)
Domain=[OVE] OS=[Windows Server 2003 R2 3790 Service Pack 1] Server=[Windows Server 2003 R2 5.2]

Server Comment
--------- -------
OVE-DC3BKUP01
....
Workgroup Master
--------- -------
OVE OVE-DC3AD01
OVEDMZ OVE-DC3ISA02

While mounting it,
AmandaBackup:~ # mount -t smbfs -o username=linuxbak,uid=amandabackup,gid=disk /media/winshare/ //10.80.101.15/LinuxBak
-bash: !,uid=amandabackup,gid=disk: event not found
AmandaBackup:~ # mount -t smbfs -o username=linuxbak /media/winshare/ //10.80.101.15/LinuxBak
Could not resolve mount point //10.80.101.15/LinuxBak
AmandaBackup:~ # mount -t smbfs -o username=linuxbak 10.90.219.64:/media/winshare/ 10.80.101.15:/LinuxBak
Could not resolve mount point 10.80.101.15:/LinuxBak

Please Help!!!!
Reply With Quote
Sponsored Links